aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-12-30 08:38:30 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-01-04 05:56:33 +0000
commitaaf8cdcf4940c10c12126ad4e01ba9bcaa88f005 (patch)
tree0cf7d249b77341f20d7645b4fde890007d2119d1
parentda42380b1eb602e3776fd9fe0a703a3fe614c185 (diff)
tegra: remove bluez fix
Revert 79fb97e839412e15a8ab639688bfd6f40b69664e since bluetooth set up is now done in upstream layer with tegra-bluetooth recipe. Change-Id: I5f632b12e0378b2df2752484422a6cabb5c538fb Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 991f83d9166b6c9bbb1431aad7cf1a7f14b12195) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5/hciattach.service14
-rw-r--r--meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5_%.bbappend41
2 files changed, 0 insertions, 55 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5/hciattach.service b/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5/hciattach.service
deleted file mode 100644
index 02faeb8f..00000000
--- a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5/hciattach.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=Run hciattach when HCI UART device becomes available
-Before=bluetooth.service
-Wants=dev-ttyTHS3.device
-After=dev-ttyTHS3.device
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/hciattach ttyTHS3 any
-ExecStartPost=/usr/sbin/rfkill unblock bluetooth
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5_%.bbappend
deleted file mode 100644
index 72551736..00000000
--- a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ /dev/null
@@ -1,41 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += " \
- file://hciattach.service \
- "
-
-SYSTEMD_SERVICE:${PN} += "hciattach.service"
-
-do_install:append() {
- install -d ${D}/${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/hciattach.service ${D}/${systemd_unitdir}/system
-}