aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2023-11-24 16:36:03 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-11-30 19:21:40 +0000
commitd39431c9a26d8162d1ab7f8304708c6d54ae9bdd (patch)
tree0eede9da4da2b3c41e2c1d2dd6763c94c81a9ca3
parent70f6019320061134acee553210b0ecd3899bbb07 (diff)
ttf-TitilliumWeb: add recipe
Add recipe that install TitilliumWeb fonts which is the current Qt Development brand corporate typeface font. https://www.qt.io/brand/development/typography Change-Id: I61c94e16fd2b0eafaaf0f0b76fba24fb31559a78 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit 39e27986c6e5c049706115d57342d3bb38732467) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb1
-rw-r--r--meta-boot2qt/recipes-graphics/fonts/ttf-titilliumweb_1.0.bb57
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
index 9ca74371..b640248c 100644
--- a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
@@ -47,6 +47,7 @@ RDEPENDS:${PN} = "\
ttf-freefont-mono \
ttf-tlwg \
otf-noto \
+ ttf-titilliumweb \
tzdata \
tzdata-americas \
tzdata-asia \
diff --git a/meta-boot2qt/recipes-graphics/fonts/ttf-titilliumweb_1.0.bb b/meta-boot2qt/recipes-graphics/fonts/ttf-titilliumweb_1.0.bb
new file mode 100644
index 00000000..160257f8
--- /dev/null
+++ b/meta-boot2qt/recipes-graphics/fonts/ttf-titilliumweb_1.0.bb
@@ -0,0 +1,57 @@
+############################################################################
+##
+## Copyright (C) 2023 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+SUMMARY = "Titillium Web Fonts"
+SECTION = "fonts"
+HOMEPAGE = "https://fonts.google.com/specimen/Titillium+Web"
+LICENSE = "OFL-1.1"
+LIC_FILES_CHKSUM = "file://ofl/titilliumweb/OFL.txt;md5=624efcc17a6f7350735d2d13054f7764"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+inherit allarch fontcache
+
+SRC_URI = "git://github.com/google/fonts;branch=main;protocol=https"
+SRCREV = "93550bd32b353b74c90d683d0f00251a3f7b314d"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -m 0755 -d ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-Regular.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-Light.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-LightItalic.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-SemiBold.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-SemiBoldItalic.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-Bold.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+ install -m 0644 ofl/titilliumweb/TitilliumWeb-BoldItalic.ttf ${D}${datadir}/fonts/truetype/titilliumweb
+}
+
+PACKAGES = "${PN}"
+FILES:${PN} += "${datadir}/fonts/truetype/titilliumweb"