aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2023-02-09 17:37:18 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-02-10 10:08:17 +0000
commit9ec5be1a4b9c55a125533f054861ffc937cc0109 (patch)
tree13b1922b6e5e95cb65fe47f0e5d1ba779df0f48c
parentdc3b7ec4f23e38b2b922cd34672020fa745f13a5 (diff)
Change imx linux kernels to use configuration fragments
Since c7e23876b199e2cfbc2aef6bf192ef50e665b1c5 prepending kernel config has not have any effect as imx kernel configuration did move to use configuration fragments. * Remove options that are already enabled in meta-freescale * Remove CONFIG_USB_SERIAL_PL2303 as it does not exist for imx Add various linux kernel profiling options via configuration fragment Change-Id: I68339981a931f437322ac70ef9ac2f362518ed8b Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit d5dad32fb95279d4cdad5bf7b8e9a2ee2338f733) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/files/profiling.cfg11
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-fslc-imx_5.%.bbappend17
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-imx_5.%.bbappend15
3 files changed, 21 insertions, 22 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/files/profiling.cfg b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/files/profiling.cfg
new file mode 100644
index 00000000..67e88e0b
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/files/profiling.cfg
@@ -0,0 +1,11 @@
+CONFIG_GENERIC_TRACER=y
+CONFIG_HAVE_DYNAMIC_FTRACE=y
+CONFIG_HAVE_FUNCTION_TRACER=y
+CONFIG_FUNCTION_TRACER=y
+CONFIG_FTRACE=y
+CONFIG_KPROBES=y
+CONFIG_KPROBE_EVENTS=y
+CONFIG_UPROBE_EVENTS=y
+CONFIG_BPF_EVENTS=y
+CONFIG_BPF_SYSCALL=y
+CONFIG_DYNAMIC_FTRACE=y
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-fslc-imx_5.%.bbappend b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-fslc-imx_5.%.bbappend
index 76793019..26730402 100644
--- a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-fslc-imx_5.%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-fslc-imx_5.%.bbappend
@@ -27,18 +27,11 @@
##
############################################################################
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
# kernel image files are not needed in the image
RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
-do_preconfigure:prepend() {
- # FunctionFS for qdbd
- echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
-
- # Enable USB serial support
- echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
-
- echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
-
- # Enable uprobe for profiling
- echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
-}
+SRC_URI:append = "\
+ file://profiling.cfg \
+"
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-imx_5.%.bbappend b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-imx_5.%.bbappend
index 9f506076..21132893 100644
--- a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-imx_5.%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-kernel/linux/linux-imx_5.%.bbappend
@@ -27,16 +27,11 @@
##
############################################################################
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
# kernel image files are not needed in the image
RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
-do_preconfigure:prepend() {
- # FunctionFS for qdbd
- echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
-
- # Enable USB serial support
- echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
-
- echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
- echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
-}
+SRC_URI:append = "\
+ file://profiling.cfg \
+"