aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-05-09 12:43:04 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-05-09 12:43:04 +0300
commit50e2273cb2525f5f129b3029f2896d024c8456c6 (patch)
tree40621ed59fbd04545fd768e4d683a63c25d2d42a
parenta159f256fe1475b9d91c0b01b0381392c396cc25 (diff)
parentf3d5b8731a54e1bad92ce5903b5a7dc7f4be6026 (diff)
Merge remote-tracking branch 'origin/morty' into pyro
* origin/morty: poky, meta-mingw: update to latest revision in morty branch qtdeviceutilities: update to latest version Add product name and Qt version to image conf Revert "Add appman versions of Kit and Qt to creator" Change-Id: I3c0e48b7c9202a7b0081f3c56966af3283cf2650
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb2
-rw-r--r--meta-boot2qt/classes/deploy-conf.bbclass8
-rwxr-xr-xmeta-boot2qt/files/configure-qtcreator.sh27
3 files changed, 8 insertions, 29 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
index 67819d76..51504639 100644
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
PR = "r0"
-DEPLOY_CONF_TYPE = "Automotive"
+DEPLOY_CONF_TYPE = "Qt Automotive Suite 5.11.0"
IMAGE_FEATURES += "\
package-management \
diff --git a/meta-boot2qt/classes/deploy-conf.bbclass b/meta-boot2qt/classes/deploy-conf.bbclass
index 228b1e20..22c6ef7d 100644
--- a/meta-boot2qt/classes/deploy-conf.bbclass
+++ b/meta-boot2qt/classes/deploy-conf.bbclass
@@ -29,15 +29,19 @@
inherit image_types
+IMAGE_DEPENDS_conf = "qtbase-native"
+
DEPLOY_CONF_NAME ?= "${MACHINE}"
DEPLOY_CONF_TYPE ?= "Boot2Qt"
IMAGE_CMD_conf() {
+ QT_VERSION=$(qmake -query QT_VERSION)
cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF
-[${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}]
+[${DEPLOY_CONF_NAME}]
platform=${MACHINE}
+product=${DEPLOY_CONF_TYPE}
+qt=Qt $QT_VERSION
os=linux
-board=
imagefile=${IMAGE_LINK_NAME}.img
asroot=true
EOF
diff --git a/meta-boot2qt/files/configure-qtcreator.sh b/meta-boot2qt/files/configure-qtcreator.sh
index 7386f704..105e4760 100755
--- a/meta-boot2qt/files/configure-qtcreator.sh
+++ b/meta-boot2qt/files/configure-qtcreator.sh
@@ -35,7 +35,7 @@ CONFIG=""
printUsage ()
{
- echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>] [--appman]"
+ echo "Usage: $0 --config <environment-setup-file> [--remove] [--qtcreator <path>] [--name <basename>]"
}
while test -n "$1"; do
@@ -43,9 +43,6 @@ while test -n "$1"; do
"--remove")
REMOVEONLY=1
;;
- "--appman")
- APPMAN=1
- ;;
"--qtcreator")
shift
QTCREATOR=$1
@@ -99,9 +96,7 @@ NAME=${NAME:-"Custom Qt ${RELEASE} ${MACHINE}"}
BASEID="byos.${RELEASE}.${MACHINE}"
${SDKTOOL} rmKit --id ${BASEID}.kit 2>/dev/null || true
-${SDKTOOL} rmKit --id ${BASEID}.am.kit 2>/dev/null || true
${SDKTOOL} rmQt --id ${BASEID}.qt || true
-${SDKTOOL} rmQt --id ${BASEID}.am.qt || true
${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc || true
${SDKTOOL} rmTC --id ProjectExplorer.ToolChain.Gcc:${BASEID}.g++ || true
${SDKTOOL} rmDebugger --id ${BASEID}.gdb 2>/dev/null || true
@@ -150,24 +145,4 @@ ${SDKTOOL} addKit \
--icon ":/boot2qt/images/B2Qt_QtC_icon.png" \
--mkspec "${MKSPEC}"
-if [ -n "${APPMAN}" ]; then
- ${SDKTOOL} addQt \
- --id "${BASEID}.am.qt" \
- --name "${NAME} [Application Manager]" \
- --type "AM.Qt" \
- --qmake "$(type -p qmake)"
-
- ${SDKTOOL} addKit \
- --id "${BASEID}.am.kit" \
- --name "${NAME} [Application Manager]" \
- --qt "${BASEID}.am.qt" \
- --debuggerid "${BASEID}.gdb" \
- --sysroot "${SDKTARGETSYSROOT}" \
- --devicetype "AM.Device.Type" \
- --Ctoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \
- --Cxxtoolchain "ProjectExplorer.ToolChain.Gcc:${BASEID}.g++" \
- --icon ":/boot2qt/images/B2Qt_QtC_icon.png" \
- --mkspec "${MKSPEC}"
-fi
-
echo "Configured Qt Creator with new kit: ${NAME}"