aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:33 +0300
committerKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:40 +0300
commitbfb97bc3cc517c42647f5f8b1308bb7b1f4c76f1 (patch)
tree534bfaffc99f288f395297c625e284fea6e50401
parenta68e1ea9b2904f7c69330e534da877cf19376219 (diff)
parent03be9b83d45659d0d98fa1bf69853e0aa297ed32 (diff)
Merge branch 'stable' into releaseQtEE_v2.1.0
* stable: wpa-supplicant: include headers and sources for external usage bootfs: need to use fakeroot for tar'ing sdk: include bluez4-dev package to sdk Create boot.tar.gz as part of the image build image: include CA certificates to image adbd: use network connection in imx53qsb sdk: libcap is required for QtWebEngine Include licenses to the image adbd: make switching between usb and ethernet easier use package groups for image content Create only tar.gz image type Change from dylan to dora brach in README mkcard: remove recipe for mkcard Change-Id: Id56ca219d05f2f833a4de3fc3ca057c5cf50a562
-rw-r--r--README12
-rw-r--r--classes/bootfs-image.bbclass51
-rw-r--r--conf/distro/b2qt.conf4
-rw-r--r--conf/distro/include/am335x-evm.conf6
-rw-r--r--conf/distro/include/beagleboard.conf14
-rw-r--r--conf/distro/include/beaglebone.conf9
-rw-r--r--conf/distro/include/imx53qsb.conf6
-rw-r--r--conf/distro/include/nitrogen6x.conf12
-rw-r--r--conf/distro/include/raspberrypi.conf8
-rw-r--r--recipes/adbd/adbd.bb6
-rwxr-xr-xrecipes/adbd/files/adb-init26
-rw-r--r--recipes/adbd/files/defaults4
-rwxr-xr-xrecipes/adbd/files/emulator/adb-init21
-rw-r--r--recipes/adbd/files/emulator/defaults4
-rw-r--r--recipes/adbd/files/imx53qsb/defaults4
-rw-r--r--recipes/adbd/files/raspberrypi/adb-init21
-rw-r--r--recipes/adbd/files/raspberrypi/defaults4
-rw-r--r--recipes/images/b2qt-embedded-image.bb51
-rwxr-xr-xrecipes/mkcard/files/mkcard.sh62
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb3
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb49
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb42
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb (renamed from recipes/mkcard/mkcard_0.5.bb)21
-rw-r--r--recipes/u-boot/u-boot-uenv-script.bb49
-rw-r--r--recipes/u-boot/u-boot-uenv-script/uEnv.txt3
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend18
27 files changed, 317 insertions, 194 deletions
diff --git a/README b/README
index ea8d7741..a2aa884e 100644
--- a/README
+++ b/README
@@ -29,26 +29,26 @@ OpenEmbedded and Yocto.
This layer depends on:
URI: git://git.openembedded.org/openembedded-core
-branch: dylan
+branch: dora
revision: HEAD
URI: git://git.openembedded.org/meta-openembedded
layer: meta-oe
-branch: dylan
+branch: dora
revision: HEAD
URI: git://git.yoctoproject.org/meta-ti
-branch: dylan
+branch: dora
revision: HEAD
URI: git://git.yoctoproject.org/meta-fsl-arm
-branch: dylan
+branch: dora
revision: HEAD
URI: git://github.com/Freescale/meta-fsl-arm-extra.git
-branch: dylan
+branch: dora
revision: HEAD
URI: git://git.yoctoproject.org/meta-raspberrypi
-branch: dylan
+branch: dora
revision: HEAD
diff --git a/classes/bootfs-image.bbclass b/classes/bootfs-image.bbclass
new file mode 100644
index 00000000..5292965b
--- /dev/null
+++ b/classes/bootfs-image.bbclass
@@ -0,0 +1,51 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+BOOTFS_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}-${DATETIME}"
+BOOTFS_LINK_NAME = "${IMAGE_BASENAME}-boot-${MACHINE}"
+
+BOOTFS_DEPENDS ?= ""
+
+fakeroot do_bootfs () {
+ if [ -n ${BOOTFS_CONTENT} ]; then
+ exit 0
+ fi
+
+ mkdir -p ${S}/bootfs
+
+ for item in ${BOOTFS_CONTENT}; do
+ src=`echo $item | awk -F':' '{ print $1 }'`
+ dst=`echo $item | awk -F':' '{ print $2 }'`
+
+ install -m 0755 ${DEPLOY_DIR_IMAGE}/$src ${S}/bootfs/$dst
+ done
+
+ cd ${S}/bootfs
+ rm -f ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
+
+ tar czvf ${DEPLOY_DIR_IMAGE}/${BOOTFS_NAME}.tar.gz .
+ ln -s ${BOOTFS_NAME}.tar.gz ${DEPLOY_DIR_IMAGE}/${BOOTFS_LINK_NAME}.tar.gz
+}
+
+addtask bootfs before do_rootfs
+
+do_bootfs[depends] += "${BOOTFS_DEPENDS}"
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index cde0b02a..66ddcf1b 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -46,3 +46,7 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED = "pulseaudio"
COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse"
COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
+MACHINE_EXTRA_INSTALL ?= ""
+
+LICENSE_CREATE_PACKAGE = "1"
+COPY_LIC_MANIFEST = "1"
diff --git a/conf/distro/include/am335x-evm.conf b/conf/distro/include/am335x-evm.conf
index 5799db71..6772a2a8 100644
--- a/conf/distro/include/am335x-evm.conf
+++ b/conf/distro/include/am335x-evm.conf
@@ -22,6 +22,12 @@
IMAGE_FSTYPES = "tar.gz"
+BOOTFS_CONTENT = "\
+ u-boot-${MACHINE}.img:u-boot.img \
+ MLO-${MACHINE}:MLO \
+ "
+BOOTFS_DEPENDS = "u-boot:do_deploy"
+
PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
diff --git a/conf/distro/include/beagleboard.conf b/conf/distro/include/beagleboard.conf
index dab0c5a1..dab9c680 100644
--- a/conf/distro/include/beagleboard.conf
+++ b/conf/distro/include/beagleboard.conf
@@ -20,15 +20,13 @@
##
#############################################################################
-IMAGE_CLASSES += "image_types_sdcard"
-IMAGE_FSTYPES = "tar.gz ext3 sdcard"
+IMAGE_FSTYPES = "tar.gz"
-BOOT_SCRIPTS = "\
- u-boot-${MACHINE}.img:u-boot.img \
- MLO-${MACHINE}:MLO \
- "
-SDCARD_GENERATION_COMMAND = "generate_imx_sdcard"
-UBOOT_SUFFIX = "img"
+BOOTFS_CONTENT = "\
+ u-boot-${MACHINE}.img:u-boot.img \
+ MLO-${MACHINE}:MLO \
+ "
+BOOTFS_DEPENDS = "u-boot:do_deploy"
PREFERRED_VERSION_libgles-omap3 = "4.09.00.01"
PREFERRED_VERSION_omap3-sgx-modules = "4.09.00.01"
diff --git a/conf/distro/include/beaglebone.conf b/conf/distro/include/beaglebone.conf
index ba13aaad..376e3c60 100644
--- a/conf/distro/include/beaglebone.conf
+++ b/conf/distro/include/beaglebone.conf
@@ -17,6 +17,15 @@
############################################################################
IMAGE_FSTYPES = "tar.gz"
+BOOTFS_CONTENT = "\
+ u-boot-${MACHINE}.img:u-boot.img \
+ MLO-${MACHINE}:MLO \
+ uEnv-${MACHINE}.txt:uEnv.txt \
+ "
+BOOTFS_DEPENDS = "u-boot:do_deploy u-boot-uenv-script:do_deploy"
+
+EXTRA_IMAGEDEPENDS += "u-boot-uenv-script"
+
PREFERRED_VERSION_libgles-omap3 = "5.01.00.01"
PREFERRED_VERSION_omap3-sgx-modules = "5.01.00.01"
diff --git a/conf/distro/include/imx53qsb.conf b/conf/distro/include/imx53qsb.conf
index d83f6b46..a7099a5c 100644
--- a/conf/distro/include/imx53qsb.conf
+++ b/conf/distro/include/imx53qsb.conf
@@ -22,6 +22,12 @@
IMAGE_FSTYPES = "tar.gz"
+BOOTFS_CONTENT = "\
+ u-boot-${MACHINE}.${UBOOT_SUFFIX}:u-boot.${UBOOT_SUFFIX} \
+ ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
+ "
+BOOTFS_DEPENDS = "u-boot:do_deploy"
+
MACHINE_EXTRA_INSTALL = "\
amd-gpu-bin-mx51 \
"
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf
index b761ddd2..2a640262 100644
--- a/conf/distro/include/nitrogen6x.conf
+++ b/conf/distro/include/nitrogen6x.conf
@@ -20,10 +20,16 @@
##
#############################################################################
-IMAGE_CLASSES += "image_types_sdcard"
-IMAGE_FSTYPES = "tar.gz ext3 sdcard"
+IMAGE_FSTYPES = "tar.gz"
-BOOT_SCRIPTS = "6x_bootscript-${MACHINE}:6x_bootscript"
+BOOTFS_CONTENT = "\
+ ${KERNEL_IMAGETYPE}:${KERNEL_IMAGETYPE} \
+ 6x_bootscript-${MACHINE}:6x_bootscript \
+ 6x_upgrade-${MACHINE}:6x_upgrade \
+ "
+BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy u-boot-script-boundary:do_deploy"
+
+EXTRA_IMAGEDEPENDS += "u-boot-script-boundary"
MACHINE_EXTRA_INSTALL = "\
libgal-mx6 \
diff --git a/conf/distro/include/raspberrypi.conf b/conf/distro/include/raspberrypi.conf
index 97513a82..61cebb4d 100644
--- a/conf/distro/include/raspberrypi.conf
+++ b/conf/distro/include/raspberrypi.conf
@@ -20,7 +20,13 @@
##
#############################################################################
-IMAGE_FSTYPES = "tar.gz ext3 rpi-sdimg"
+IMAGE_FSTYPES = "tar.gz"
+
+BOOTFS_CONTENT = "\
+ bcm2835-bootfiles/*: \
+ ${KERNEL_IMAGETYPE}:kernel.img \
+ "
+BOOTFS_DEPENDS = "bcm2835-bootfiles:do_deploy virtual/kernel:do_deploy"
PREFERRED_PROVIDER_virtual/libgles1 = "userland"
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index 1feb7c34..9e3ed67b 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https \
file://adbd.patch;striplevel=2 \
file://Makefile.adbd \
file://adb-init \
+ file://defaults \
"
S = "${WORKDIR}/git/adb"
@@ -44,7 +45,7 @@ FILES_${PN} += "${bindir}/adbd"
do_configure() {
if [ -n "${ADB_PRODUCTID}" ]; then
- sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/adb-init
+ sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults
fi
}
@@ -58,6 +59,9 @@ do_install() {
install -m 0755 -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/
+
+ install -m 0755 -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd
}
INITSCRIPT_NAME = "adb-init"
diff --git a/recipes/adbd/files/adb-init b/recipes/adbd/files/adb-init
index 6faed600..92500d70 100755
--- a/recipes/adbd/files/adb-init
+++ b/recipes/adbd/files/adb-init
@@ -2,25 +2,27 @@
DAEMON=/usr/bin/adbd
-VENDOR=0x18d1
-PRODUCT=0x0000
-SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
+. /etc/default/adbd
case "$1" in
start)
- modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL}
- mkdir -p /dev/usb-ffs
- chmod 770 /dev/usb-ffs
- mkdir -p /dev/usb-ffs/adb
- chmod 770 /dev/usb-ffs/adb
- mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0
+ if [ "$USE_ETHERNET" = "no" ]; then
+ modprobe g_ffs idVendor=${VENDOR} idProduct=${PRODUCT} iSerialNumber=${SERIAL}
+ mkdir -p /dev/usb-ffs
+ chmod 770 /dev/usb-ffs
+ mkdir -p /dev/usb-ffs/adb
+ chmod 770 /dev/usb-ffs/adb
+ mount -t functionfs adb /dev/usb-ffs/adb -o uid=0,gid=0
+ fi
start-stop-daemon --start --quiet --exec $DAEMON &
;;
stop)
start-stop-daemon --stop --quiet --exec $DAEMON
- sleep 1
- umount /dev/usb-ffs/adb
- rmmod g_ffs
+ if [ "$USE_ETHERNET" = "no" ]; then
+ sleep 1
+ umount /dev/usb-ffs/adb
+ rmmod g_ffs
+ fi
;;
restart)
start-stop-daemon --stop --quiet --exec $DAEMON
diff --git a/recipes/adbd/files/defaults b/recipes/adbd/files/defaults
new file mode 100644
index 00000000..d2a3cc0a
--- /dev/null
+++ b/recipes/adbd/files/defaults
@@ -0,0 +1,4 @@
+VENDOR=0x18d1
+PRODUCT=0x0000
+SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
+USE_ETHERNET=no
diff --git a/recipes/adbd/files/emulator/adb-init b/recipes/adbd/files/emulator/adb-init
deleted file mode 100755
index 8910e0e4..00000000
--- a/recipes/adbd/files/emulator/adb-init
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-DAEMON=/usr/bin/adbd
-
-case "$1" in
-start)
- start-stop-daemon --start --quiet --exec $DAEMON &
- ;;
-stop)
- start-stop-daemon --stop --quiet --exec $DAEMON
- ;;
-restart)
- start-stop-daemon --stop --quiet --exec $DAEMON
- sleep 1
- start-stop-daemon --start --quiet --exec $DAEMON &
- ;;
-*)
- echo "Usage: $0 {start|stop|restart}"
- exit 1
-esac
-exit 0
diff --git a/recipes/adbd/files/emulator/defaults b/recipes/adbd/files/emulator/defaults
new file mode 100644
index 00000000..0fbba4cb
--- /dev/null
+++ b/recipes/adbd/files/emulator/defaults
@@ -0,0 +1,4 @@
+VENDOR=0x18d1
+PRODUCT=0x0000
+SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
+USE_ETHERNET=yes
diff --git a/recipes/adbd/files/imx53qsb/defaults b/recipes/adbd/files/imx53qsb/defaults
new file mode 100644
index 00000000..0fbba4cb
--- /dev/null
+++ b/recipes/adbd/files/imx53qsb/defaults
@@ -0,0 +1,4 @@
+VENDOR=0x18d1
+PRODUCT=0x0000
+SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
+USE_ETHERNET=yes
diff --git a/recipes/adbd/files/raspberrypi/adb-init b/recipes/adbd/files/raspberrypi/adb-init
deleted file mode 100644
index 8910e0e4..00000000
--- a/recipes/adbd/files/raspberrypi/adb-init
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-DAEMON=/usr/bin/adbd
-
-case "$1" in
-start)
- start-stop-daemon --start --quiet --exec $DAEMON &
- ;;
-stop)
- start-stop-daemon --stop --quiet --exec $DAEMON
- ;;
-restart)
- start-stop-daemon --stop --quiet --exec $DAEMON
- sleep 1
- start-stop-daemon --start --quiet --exec $DAEMON &
- ;;
-*)
- echo "Usage: $0 {start|stop|restart}"
- exit 1
-esac
-exit 0
diff --git a/recipes/adbd/files/raspberrypi/defaults b/recipes/adbd/files/raspberrypi/defaults
new file mode 100644
index 00000000..0fbba4cb
--- /dev/null
+++ b/recipes/adbd/files/raspberrypi/defaults
@@ -0,0 +1,4 @@
+VENDOR=0x18d1
+PRODUCT=0x0000
+SERIAL=$(hostname)-$(sed -e 's/://g' /sys/class/net/eth0/address)
+USE_ETHERNET=yes
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
index a9ec3bf5..8daffbd3 100644
--- a/recipes/images/b2qt-embedded-image.bb
+++ b/recipes/images/b2qt-embedded-image.bb
@@ -33,51 +33,10 @@ IMAGE_FEATURES += "\
"
inherit core-image
-
-EXTRA_IMAGEDEPENDS_mx6 += "u-boot-script-boundary"
-
-MACHINE_EXTRA_INSTALL ?= ""
-
-GSTREAMER_EXTRA_INSTALL = "\
- gst-meta-video \
- gst-meta-audio \
- gst-plugins-good \
- gst-plugins-base-app \
- gst-plugins-good-videofilter \
- gst-plugins-good-id3demux \
- gst-plugins-good-auparse \
- gst-plugins-good-isomp4 \
- gst-plugins-ugly-rmdemux \
- gst-plugins-ugly-asf \
- gst-plugins-ugly-a52dec \
- gst-ffmpeg \
- "
-
-TOOLS_EXTRA_INSTALL = "\
- adbd \
- ldd \
- binutils \
- binutils-symlinks \
- "
+inherit bootfs-image
IMAGE_INSTALL += "\
- kernel-modules \
- psplash \
- openssh-sftp-server \
- openssl \
- libpng \
- jpeg \
- tiff \
- libxslt \
- icu \
- freetype \
- fontconfig \
- liberation-fonts \
- tslib \
- tslib-calibrate \
- alsa-utils-amixer \
- hunspell \
- ${GSTREAMER_EXTRA_INSTALL} \
- ${TOOLS_EXTRA_INSTALL} \
- ${MACHINE_EXTRA_INSTALL} \
- "
+ packagegroup-b2qt-embedded-base \
+ packagegroup-b2qt-embedded-tools \
+ packagegroup-b2qt-embedded-gstreamer \
+ "
diff --git a/recipes/mkcard/files/mkcard.sh b/recipes/mkcard/files/mkcard.sh
deleted file mode 100755
index e75a1767..00000000
--- a/recipes/mkcard/files/mkcard.sh
+++ /dev/null
@@ -1,62 +0,0 @@
-#! /bin/sh
-# mkcard.sh v0.5
-# (c) Copyright 2009 Graeme Gregory <dp@xora.org.uk>
-# Licensed under terms of GPLv2
-#
-# Parts of the procudure base on the work of Denys Dmytriyenko
-# http://wiki.omap.com/index.php/MMC_Boot_Format
-
-export LC_ALL=C
-
-if [ $# -ne 1 ]; then
- echo "Usage: $0 <drive>"
- exit 1;
-fi
-
-DRIVE=$1
-
-dd if=/dev/zero of=$DRIVE bs=1024 count=1024
-
-SIZE=`fdisk -l $DRIVE | grep Disk | grep bytes | awk '{print $5}'`
-
-echo DISK SIZE - $SIZE bytes
-
-CYLINDERS=`echo $SIZE/255/63/512 | bc`
-
-echo CYLINDERS - $CYLINDERS
-
-{
-echo ,9,0x0C,*
-echo ,,,-
-} | sfdisk -D -H 255 -S 63 -C $CYLINDERS $DRIVE
-
-sleep 1
-
-# handle various device names.
-# note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1
-# won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572
-
-PARTITION1=${DRIVE}1
-if [ ! -b ${PARTITION1} ]; then
- PARTITION1=${DRIVE}p1
-fi
-
-PARTITION2=${DRIVE}2
-if [ ! -b ${PARTITION2} ]; then
- PARTITION2=${DRIVE}p2
-fi
-
-# now make partitions.
-if [ -b ${PARTITION1} ]; then
- umount ${PARTITION1}
- mkfs.vfat -F 32 -n "boot" ${PARTITION1}
-else
- echo "Cant find boot partition in /dev"
-fi
-
-if [ -b ${PARITION2} ]; then
- umount ${PARTITION2}
- mke2fs -t ext3 -j -L "rootfs" ${PARTITION2}
-else
- echo "Cant find rootfs partition in /dev"
-fi
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index f32bac4c..9c92438a 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -28,7 +28,6 @@ LICENSE = "CLOSED"
require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
RDEPENDS_${PN} = "\
- mkcard-nativesdk \
python-nativesdk \
python-subprocess-nativesdk \
"
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
index 4cdd4047..457ea56c 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
@@ -47,5 +47,8 @@ RDEPENDS_${PN} += "\
udev-dev \
tslib-dev \
hunspell-dev \
+ libcap-dev \
+ wpa-supplicant-dev \
+ ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \
${MACHINE_EXTRA_INSTALL_SDK} \
"
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 00000000..0942a7e7
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,49 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
+LICENSE = "CLOSED"
+PR = "r0"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = "\
+ kernel-modules \
+ adbd \
+ psplash \
+ openssh-sftp-server \
+ openssl \
+ libpng \
+ jpeg \
+ tiff \
+ libxslt \
+ icu \
+ freetype \
+ fontconfig \
+ liberation-fonts \
+ tslib \
+ tslib-calibrate \
+ alsa-utils-amixer \
+ hunspell \
+ ca-certificates \
+ ${MACHINE_EXTRA_INSTALL} \
+ "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
new file mode 100644
index 00000000..f6a8a54f
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
@@ -0,0 +1,42 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
+LICENSE = "CLOSED"
+PR = "r0"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = "\
+ gst-meta-video \
+ gst-meta-audio \
+ gst-plugins-good \
+ gst-plugins-base-app \
+ gst-plugins-good-videofilter \
+ gst-plugins-good-id3demux \
+ gst-plugins-good-auparse \
+ gst-plugins-good-isomp4 \
+ gst-plugins-ugly-rmdemux \
+ gst-plugins-ugly-asf \
+ gst-plugins-ugly-a52dec \
+ gst-ffmpeg \
+ "
diff --git a/recipes/mkcard/mkcard_0.5.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index 8d71f81b..61ca2111 100644
--- a/recipes/mkcard/mkcard_0.5.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -20,17 +20,14 @@
##
#############################################################################
-DESCRIPTION = "mkcard.sh v0.5"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe"
-SECTION = "devel"
-PR = "0"
+DESCRIPTION = "Additional tools packagegroup for B2Qt embedded Linux image"
+LICENSE = "CLOSED"
+PR = "r0"
-SRC_URI = "file://mkcard.sh"
+inherit packagegroup
-do_install () {
- install -d ${D}${bindir}/
- install -m 0755 ${WORKDIR}/mkcard.sh ${D}${bindir}/
-}
-
-BBCLASSEXTEND = "nativesdk"
+RDEPENDS_${PN} = "\
+ ldd \
+ binutils \
+ binutils-symlinks \
+ "
diff --git a/recipes/u-boot/u-boot-uenv-script.bb b/recipes/u-boot/u-boot-uenv-script.bb
new file mode 100644
index 00000000..b15dd1fe
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script.bb
@@ -0,0 +1,49 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+DESCRIPTION = "U-Boot script to start up BeagleBone Black"
+LICENSE = "CLOSED"
+PR = "r0"
+
+COMPATIBLE_MACHINE = "(beaglebone)"
+PV = "20140225"
+
+SRC_URI = "file://uEnv.txt"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
+
+ cd ${DEPLOYDIR}
+ rm -f uEnv-${MACHINE}.txt
+ ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
+}
+
+addtask deploy after do_install before do_build
+
+do_compile[noexec] = "1"
+do_install[noexec] = "1"
+do_populate_sysroot[noexec] = "1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/u-boot/u-boot-uenv-script/uEnv.txt b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
new file mode 100644
index 00000000..f8385a40
--- /dev/null
+++ b/recipes/u-boot/u-boot-uenv-script/uEnv.txt
@@ -0,0 +1,3 @@
+bootfile=zImage
+optargs=consoleblank=0 vt.global_cursor_default=0
+mmcboot=echo Booting from mmc ...; run mmcargs; bootz ${kloadaddr} - ${fdtaddr}
diff --git a/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend
new file mode 100644
index 00000000..9a200b20
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -0,0 +1,18 @@
+do_install_append () {
+ install -d ${D}${includedir}/wpa-supplicant
+
+ install -m 0644 ${S}/src/common/wpa_ctrl.c ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/common/wpa_ctrl.h ${D}${includedir}/wpa-supplicant/
+
+ install -m 0644 ${S}/src/utils/build_config.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/common.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/includes.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/os.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/os_unix.c ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/trace.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/wpa_debug.h ${D}${includedir}/wpa-supplicant/
+ install -m 0644 ${S}/src/utils/wpabuf.h ${D}${includedir}/wpa-supplicant/
+}
+
+FILES_${PN}-dev += "${includedir}/wpa-supplicant/*"
+