aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-03-07 15:52:32 +0200
committerRisto Avila <risto.avila@theqtcompany.com>2016-03-08 07:29:34 +0000
commit6136e6009970859fc02477cdd37fb29a2031566f (patch)
treed9e111fe72ed1703541b48dd8a3298d5a294db03
parent7eba608a92ee934440a5468ed81237bbae90f12a (diff)
RPi2: add support for touch display
The RPi touch display need the rpi-tf5604 devicetree to enable touch. Add it to the kernel build and enabled it in the config.txt. Update meta-raspberrypi to latest revision for the PiTFT support. Change-Id: Ibc5ba51c844bc17b541d8021a755f141a5ff2a0c Reviewed-by: Risto Avila <risto.avila@theqtcompany.com>
-rw-r--r--conf/bblayers.conf.rpi.sample1
-rw-r--r--conf/distro/include/raspberrypi2.conf4
-rw-r--r--meta-raspberrypi-extras/conf/layer.conf32
-rw-r--r--meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend27
-rw-r--r--scripts/manifest.xml2
5 files changed, 65 insertions, 1 deletions
diff --git a/conf/bblayers.conf.rpi.sample b/conf/bblayers.conf.rpi.sample
index 6b12ac53..3be5ea39 100644
--- a/conf/bblayers.conf.rpi.sample
+++ b/conf/bblayers.conf.rpi.sample
@@ -37,6 +37,7 @@ BBLAYERS ?= " \
${BSPDIR}/sources/meta-openembedded/meta-initramfs \
${BSPDIR}/sources/meta-openembedded/meta-ruby \
${BSPDIR}/sources/meta-b2qt \
+ ${BSPDIR}/sources/meta-b2qt/meta-raspberrypi-extras \
${BSPDIR}/sources/meta-mingw \
${BSPDIR}/sources/meta-qt5 \
"
diff --git a/conf/distro/include/raspberrypi2.conf b/conf/distro/include/raspberrypi2.conf
index 7e4c0577..040ea9b7 100644
--- a/conf/distro/include/raspberrypi2.conf
+++ b/conf/distro/include/raspberrypi2.conf
@@ -46,3 +46,7 @@ module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1"
GPU_MEM = "256"
# video camera support
VIDEO_CAMERA = "1"
+RPI_FT5604 = "1"
+
+KERNEL_DEVICETREE += "overlays/rpi-ft5406-overlay.dtb"
+MACHINE_FEATURES += "pitft"
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf
new file mode 100644
index 00000000..641e0f6b
--- /dev/null
+++ b/meta-raspberrypi-extras/conf/layer.conf
@@ -0,0 +1,32 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "b2qt_rpi"
+BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt_rpi = "20"
diff --git a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 00000000..b711ab51
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,27 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+do_deploy_append() {
+ if [ "${RPI_FT5604}" = "1" ]; then
+ echo "# Enable rpi-ft5604 touch" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=rpi-ft5406" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+}
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 71686c11..7299efa6 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -45,7 +45,7 @@
groups="notdefault,ti,bbb"/>
<project name="meta-raspberrypi"
remote="yocto"
- revision="6314f668fa14473463bb777ffaf778333fea16eb"
+ revision="a42a1706de91ed03ae8798c7f9e70c30cebcf7de"
path="sources/meta-raspberrypi"
groups="notdefault,rpi"/>
<project name="meta-fsl-arm-extra"