aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-22 15:51:00 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-24 08:23:05 +0000
commit4ee7fff912a0c2bef6a38ba561f9423ba9d2cc33 (patch)
tree712704a4112aa566093407cda07e511fa3f6aec1
parent7be5774920e168c2cfff9a25a068aa247a474b69 (diff)
qtgamepad: add QtGamePad to the image
And build qt3d with the gamepad support enabled. QtGamePad depends on libsdl2 which needs adjustment to build without x11. Change-Id: I03e42136ab4d50d66b0d95f14ad8f21922e03477 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-graphics/libsdl2/libsdl2_%.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb1
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb1
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend30
-rw-r--r--meta-fsl-extras/recipes/libsdl2/libsdl2_%.bbappend30
5 files changed, 92 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-graphics/libsdl2/libsdl2_%.bbappend b/meta-boot2qt-distro/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644
index 00000000..bef2c7ab
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index c1d7f26f..281d9b6d 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -54,6 +54,7 @@ RDEPENDS_${PN} += " \
qtdeclarative-dev \
qtdeclarative-staticdev \
qtdeviceutilities-dev \
+ qtgamepad-dev \
qtgraphicaleffects-dev \
qtimageformats-dev \
qtlocation-dev \
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index 38bddaa6..6b78a823 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -46,6 +46,7 @@ RDEPENDS_${PN} += " \
qtdeclarative \
qtdeclarative-tools \
qtdeviceutilities \
+ qtgamepad \
qtgraphicaleffects \
qtimageformats \
qtlocation \
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend
new file mode 100644
index 00000000..d2906b94
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qt3d_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG += "qtgamepad"
diff --git a/meta-fsl-extras/recipes/libsdl2/libsdl2_%.bbappend b/meta-fsl-extras/recipes/libsdl2/libsdl2_%.bbappend
new file mode 100644
index 00000000..4d6a52be
--- /dev/null
+++ b/meta-fsl-extras/recipes/libsdl2/libsdl2_%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+CFLAGS += "-DLINUX=1 -DEGL_API_FB=1"