aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@qt.io>2016-06-07 15:48:17 +0200
committerGatis Paeglis <gatis.paeglis@qt.io>2016-06-08 10:17:44 +0000
commitd395b7e22218b742f2e28b292f2c0a29a6ab630a (patch)
tree2a32ee6c32c7312afcf4981b3b2f8cced317bca0
parent4226b6fa6410daa102b09d7ecf46f84ad745c21d (diff)
Add b2qt-ota recipe.
Change-Id: I002067b938fa19cb35fa62db700cde2cc9ad7922 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/b2qt-addons/b2qt-ota.bb43
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb1
-rw-r--r--recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb1
4 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-ota.bb b/recipes-qt/b2qt-addons/b2qt-ota.bb
new file mode 100644
index 00000000..9c5929c4
--- /dev/null
+++ b/recipes-qt/b2qt-addons/b2qt-ota.bb
@@ -0,0 +1,43 @@
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "Qt OTA Update module"
+LICENSE = "The-Qt-Company-DCLA-2.1"
+LIC_FILES_CHKSUM = "file://src/lib/qotaclient.h;md5=da66cc6e520f8151501c0f6c11480077;beginline=1;endline=28"
+
+inherit qt5-module
+
+SRC_URI = " \
+ git://codereview.qt-project.org/tqtc-boot2qt/ota;branch=${BRANCH};protocol=ssh \
+ "
+
+SRCREV = "d8d81530692454e4e38f682f6a09049d27b8c1ad"
+BRANCH = "master"
+PV = "git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "qtbase qtdeclarative"
+RDEPENDS_${PN} = "ostree"
+
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index afe74853..aee96d96 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -37,6 +37,7 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS_${PN} += " \
b2qt-appcontroller \
b2qt-utils \
+ b2qt-ota \
qtivi \
neptune-ui \
neptune-ui-apps \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
index 9c2008dc..ff2d2066 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -37,6 +37,7 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS_${PN} += " \
b2qt-appcontroller \
b2qt-utils \
+ b2qt-ota \
b2qt-launcher \
b2qt-demos \
${@base_contains("DISTRO_FEATURES", "wayland", "democompositor", "", d)} \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index cd1f2d88..5286ac5a 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -68,6 +68,7 @@ RDEPENDS_${PN} += " \
qtxmlpatterns-dev \
\
b2qt-utils-dev \
+ b2qt-ota-dev \
qtcharts-dev \
qtdatavis3d-dev \
qtvirtualkeyboard-dev \