aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-03-10 06:56:25 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-03-17 07:47:02 +0000
commit9f1af6a4e57285c57cce551787fff030ad31517e (patch)
tree0d09d6789b8c1130af60236cdb6f74f44f9e15ec
parent492c4613cb617d2af6864c9496e90cd95b1a1842 (diff)
toradex: add mount point for boot files
Toradex boot sequence wants to have the boot partition mounted in /boot. Pick-to: 6.3 6.2 Change-Id: I6fe8047fb27745c1d2ed4badbbb406b1cca1f80e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-core/base-files/base-files_%.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-core/base-files/base-files_%.bbappend b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 00000000..b89c03eb
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,35 @@
+############################################################################
+##
+## Copyright (C) 2022 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_install:append() {
+ # add toradex specific mount point
+ cat >> ${D}${sysconfdir}/fstab <<EOF
+/dev/boot-part /boot auto noatime,noauto 0 0
+EOF
+}