aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-05 13:34:42 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-07 10:40:52 +0000
commit29b65f9918d27aa05d30c7321f8e3a14b50422c4 (patch)
tree5f3f7bee51611e2a465e2e750819db844154c5e5
parentbb2f6ef6d524a0111fd50abb90d86060e30d2102 (diff)
qt5: Enable Link Time Optimization
Re-enable building qtbase and rest of the modules with Link Time Optimization that significantly improves performance and reduces binary sizes. Exclude it from QtWebEngine, as it produces unstable binaries for ARM. Task-number: QTBUG-68688 Change-Id: Ic2448229b878c5b16febf4773dba6c52f5983fd5 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend1
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend31
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
index aac5d20a..f24556e4 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
@@ -44,6 +44,7 @@ PACKAGECONFIG += " \
icu \
libinput \
linuxfb \
+ ltcg \
sql-sqlite \
tslib \
xkbcommon-evdev \
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend
new file mode 100644
index 00000000..cfd3a39c
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,31 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# QTBUG-70348
+EXTRA_QMAKEVARS_PRE_append_arm = " CONFIG-=ltcg"