aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-09-10 12:04:10 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-09-10 12:14:36 +0300
commit3759e032e636185210f8d33304a0b6da02899539 (patch)
tree3b56913894bf046d3a250c8faf99538b801794a3
parentd8a1f6681d488e193a39468614c13a3febf8e5b8 (diff)
parent16351237e2a7d94155a5e2e3ce1e055893ed816d (diff)
Merge "Merge remote-tracking branch 'origin/QtAS-5.12.4' into sumo"
-rwxr-xr-xb2qt-init-build-env2
-rw-r--r--meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf32
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb2
-rwxr-xr-xscripts/setup-environment.sh2
5 files changed, 36 insertions, 4 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index bec9db92..d335f332 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -115,7 +115,7 @@ get_groups() {
all)
PROJECT_GROUPS="external"
;;
- imx8qmmek|imx8mqevk)
+ imx8*)
PROJECT_GROUPS="fsl-imx8"
;;
apalis-imx8|colibri-imx8qxp)
diff --git a/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf b/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf
new file mode 100644
index 00000000..3445d5c2
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+include conf/distro/include/fsl-imx8.inc
+
+DEPLOY_CONF_NAME = "NXP i.MX 8QuadXPlus MEK"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index aefabbe4..bf8d7732 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "457ba7b13a8fa21803ea52ec39aaddd7eee5e44a"
+SRCREV = "ff4bc7cbaf5827736fda4b1a8c85fcdd351680c1"
DEPENDS = "qtbase qtdeclarative libyaml libarchive \
${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index f572cd4d..c99f8943 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -50,7 +50,7 @@ SRC_URI += " \
file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
"
-SRCREV_qtivi = "910b074f1819e0b3c3a67a7d98f20a97f96ec993"
+SRCREV_qtivi = "346d123b3e8c7f0e24fd465a00974f4d2189fd08"
SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e"
SRCREV = "${SRCREV_qtivi}"
SRCREV_FORMAT = "qtivi_qface"
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index c4f6a3d7..05e70159 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -56,7 +56,7 @@ BUILDDIRECTORY=${BUILDDIRECTORY:-build-${MACHINE}}
if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
case ${MACHINE} in
- imx8qmmek|imx8mqevk)
+ imx8*)
LAYERSCONF="bblayers.conf.fsl-imx8.sample"
;;
apalis-imx8|colibri-imx8qxp)