aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Zamotaev <nzamotaev@luxoft.com>2019-10-04 19:28:08 +0300
committerNikolay Zamotaev <nzamotaev@luxoft.com>2019-10-12 01:28:02 +0300
commit56124e6eb5f95a42b178c2e16eafe0eff716d253 (patch)
tree79b0285775defe9f6aad5acf31517e2d5b9d0fa6
parent37adc03475e91f73c54ebbc32ad5bff881788095 (diff)
Fix for ivigenerator use in boot2qt on windows platformv5.13.1_QtAS
This change includes prepackaged python module dependencies for ivigenerator for windows (mingw, for both i386 and amd64 architectures). Task-number: AUTOSUITE-176 Change-Id: Ic2580500ba70d70bbcdb90bb85d838137252aba8 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-boot2qt-distro/conf/distro/b2qt.conf1
-rw-r--r--meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc9
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc51
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb3
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb1
6 files changed, 66 insertions, 2 deletions
diff --git a/meta-boot2qt-distro/conf/distro/b2qt.conf b/meta-boot2qt-distro/conf/distro/b2qt.conf
index 7a70b5c1..76d6a10c 100644
--- a/meta-boot2qt-distro/conf/distro/b2qt.conf
+++ b/meta-boot2qt-distro/conf/distro/b2qt.conf
@@ -88,3 +88,4 @@ LICENSE_CREATE_PACKAGE = "1"
COPY_LIC_MANIFEST = "1"
include conf/distro/include/${MACHINE}.conf
+include conf/distro/include/preferred-providers-${SDK_OS}.inc
diff --git a/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc b/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc
new file mode 100644
index 00000000..28dc3a71
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc
@@ -0,0 +1,9 @@
+PREFERRED_PROVIDER_nativesdk-antlr4-python3-runtime ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3 ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-jinja2 ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-markupsafe ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-path.py ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-pathtools ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-qface ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-setuptools-scm ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-watchdog ?= "nativesdk-prebuild-python"
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
index 3d8c083f..f7c33a13 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
@@ -39,15 +39,64 @@ PV = "3.5.2"
S = "${WORKDIR}"
+PROVIDES += " \
+ python3 \
+ python3-watchdog \
+ python3-path.py \
+ antlr4-python3-runtime \
+ python3-jinja2 \
+ python3-markupsafe \
+ qface \
+ "
+
+RPROVIDES_${PN} += " \
+ python3-pkgutil \
+ python3-xml \
+ python3-crypt \
+ python3-compile \
+ python3-netserver \
+ python3-compression \
+ python3-numbers \
+ python3-unittest \
+ python3-netclient \
+ python3-math \
+ python3-ctypes \
+ python3-html \
+ python3-json \
+ python3-datetime \
+ python3-distutils \
+ python3-shell \
+ python3-stringold \
+ python3-email \
+ python3-threading \
+ python3-pprint \
+ python3-plistlib \
+ python3-io \
+ python3-pickle \
+ \
+ qface \
+ python3-jinja2 \
+ python3-watchdog \
+ python3-path.py \
+ python3-markupsafe \
+ antlr4-python3-runtime \
+ "
+
do_install() {
install -d ${D}${includedir}/${PYTHON_DIR}
install -m 0644 ${S}/include/* ${D}${includedir}/${PYTHON_DIR}
+ install -d ${D}${bindir}
install -d ${D}${libdir}
+ install -d ${D}${libdir}/${PYTHON_DIR}
install -m 0644 ${S}/libs/*.a ${D}${libdir}
+ cp -r --no-preserve=ownership ${S}/Lib/* ${D}/${libdir}/${PYTHON_DIR}/
+ cp -r --no-preserve=ownership ${S}/Lib/site-packages/* ${D}/${bindir}/
- install -d ${D}${bindir}
+ install -m 0644 ${S}/*.pyd ${D}/${bindir}/
install -m 0644 ${S}/python.exe ${D}${bindir}
+ install -m 0644 ${S}/python.exe ${D}${bindir}/python3.exe
install -m 0644 ${S}/python35.dll ${D}${bindir}
install -m 0644 ${S}/python35.zip ${D}${bindir}
+ install -m 0644 ${S}/Scripts/* ${D}${bindir}
}
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
index 2ff4f761..78b9f8f9 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
@@ -34,9 +34,12 @@ COMPATIBLE_HOST = "i686.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-win32.zip;name=modules \
"
SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
+SRC_URI[modules.md5sum] = "c44f01754f9975ae6d910783d69e6a28"
+SRC_URI[modules.sha256sum] = "13bbbcc724165407cfbec8d23424bd94f45541092f08523f0064f75e6c4de5ae"
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
index 8e69fbd7..71b6c4b6 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
@@ -34,9 +34,12 @@ COMPATIBLE_HOST = "x86_64.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-amd64.zip;name=modules \
"
SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"
+SRC_URI[modules.md5sum] = "bf1deaf0a0b807bcd52e11d15892fec2"
+SRC_URI[modules.sha256sum] = "cd82789e05bf763b3b67f8e3ec78873c69ce922a13e391298be198702967d6da"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 06003234..019e687d 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -69,7 +69,6 @@ PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects
PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native remoteobjects-native"
PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
-PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
ALLOW_EMPTY_${PN}-tools = "1"