aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-20 13:48:43 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-08-24 09:22:19 +0000
commit5708d0d71679fc85c0efd4de234a8f1f030d63dd (patch)
tree4c0bbdf5a09914428c5fdbc1c7af9e8941dd4b22
parentfeac3edc2ab20b106e1f50f3401d60a2355f5178 (diff)
qtquicktimeline: fetch from public repository
Repository is now public, so we can treat it as a regular qt5 module. Remove qmlpreview recipe as that's part of qtdeclarative in 5.12. Task-number: QTPM-1153 Change-Id: I9bf608136c956124c83c23d50b52f4050bde10c5 Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb5
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb5
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb44
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb17
4 files changed, 11 insertions, 60 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 646239f5..c1d7f26f 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -62,6 +62,7 @@ RDEPENDS_${PN} += " \
qtotaupdate-dev \
qtquickcontrols-dev \
qtquickcontrols2-dev \
+ qtquicktimeline-dev \
qtremoteobjects-dev \
qtscxml-dev \
qtsensors-dev \
@@ -77,7 +78,3 @@ RDEPENDS_${PN} += " \
qtwebchannel-dev \
qtxmlpatterns-dev \
"
-
-RDEPENDS_${PN} += "\
- ${@ "qtquicktimeline-dev" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \
- "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index cd5f35f5..38bddaa6 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -54,6 +54,7 @@ RDEPENDS_${PN} += " \
qtotaupdate \
qtquickcontrols \
qtquickcontrols2 \
+ qtquicktimeline \
qtremoteobjects \
qtscxml \
qtsensors \
@@ -79,7 +80,3 @@ RDEPENDS_${PN} += " \
qtxmlpatterns \
qtvirtualkeyboard \
"
-
-RDEPENDS_${PN} += "\
- ${@ "qtquicktimeline qmlpreview" if (d.getVar("QT_INTERNAL_BUILD")) else "" } \
- "
diff --git a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb b/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
deleted file mode 100644
index 1de4199b..00000000
--- a/meta-boot2qt/recipes-qt/qt5/qmlpreview_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "QML Live Preview debug service"
-LICENSE = "The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
-
-inherit qt5-module
-require recipes-qt/qt5/qt5-git.inc
-
-SRCREV = "6ae4a9da17e53bbb7c1729c24f58141a33bbcb9b"
-BRANCH = "master"
-
-SRC_URI = " \
- git://codereview.qt-project.org/qt/tqtc-qmlpreview;branch=${BRANCH};protocol=ssh \
- "
-
-DEPENDS = "qtbase qtdeclarative"
diff --git a/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
index 74a66c08..a28022db 100644
--- a/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
+++ b/meta-boot2qt/recipes-qt/qt5/qtquicktimeline_git.bb
@@ -28,17 +28,18 @@
############################################################################
DESCRIPTION = "Qt Quick Timeline"
-LICENSE = "The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
+LICENSE = "( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ "
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "7ee1adca536b422623de1fe8da44135aeee6e9cf"
-BRANCH = "dev"
+DEPENDS = "qtbase qtdeclarative"
-SRC_URI = " \
- git://codereview.qt-project.org/qt/tqtc-qtquicktimeline;branch=${BRANCH};protocol=ssh \
- "
+QT_MODULE_BRANCH = "dev"
-DEPENDS = "qtbase qtdeclarative"
+SRCREV = "42415a5b7a13b92701ccc7be70f9cdb7e522a3ea"