aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-devtools
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-01-28 13:26:19 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-02-06 07:19:06 +0000
commitb469160565b5af288f840411a8f2de570392c74e (patch)
tree52791294ad32a63cd3f20141808c2057e8a92096 /meta-boot2qt-distro/recipes-devtools
parent7e819daf7b4d0fcd673cc8e54a73130476b8e225 (diff)
gcc-cross-canadian: Do not create symlink to real-ld
real-ld is always used if that is found, which means you cannot switch between bfd and gold linkers using -fuse-ld=gold. This reverts commit cdd86896c8d29135f937968e9aa07f919cf543d3 used in openembedded-core. Task-number: QTBUG-73216 Change-Id: I3776c7cade02bedcec75d1b2859a8d3647479fff Reviewed-by: Michal Klocek <michal.klocek@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
new file mode 100644
index 00000000..66e79ec1
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
@@ -0,0 +1,33 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_install_append () {
+ # remove real-ld symlink
+ rm ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/real-ld${EXEEXT}
+}