aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-devtools
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-05-25 13:22:07 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2021-06-07 09:31:19 +0300
commitbb7dae27d8c23b361b82020a4644baeb6b3003c8 (patch)
tree88e8a6d1327bfbc04268e121d61605ea8e67d47b /meta-boot2qt-distro/recipes-devtools
parent487696a17d6763ea0e6b7bde83c31517deda9405 (diff)
cmake: enable zstd support
Qt uses CMake's archiving that depends on zstd support (QTBUG-89108). Make sure that zstd is supported, direct dependency on cmake-native and through libarchive for nativesdk-cmake. Backported from oe-core master. Change-Id: I99e823d65072123db8f231e224d638e879aa9a46 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake-native_%.bbappend30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake-native_%.bbappend b/meta-boot2qt-distro/recipes-devtools/cmake/cmake-native_%.bbappend
new file mode 100644
index 00000000..dd701a4c
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-devtools/cmake/cmake-native_%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2021 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += "zstd-native"