aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-08-21 11:14:29 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2020-09-03 14:38:44 +0300
commit2b3b63a700cfa1cf7142bf0c4d0f2b3b85c66daa (patch)
treee7e79cdb43edaf36775bc7ebbfc73af1860cc3ab /meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
parentb3ef0f2a1d80a368417ceff5e7489fae5de068ae (diff)
Upgrade to Qt 6
Move to using Qt 6 from new meta-qt6 layer. Change all qt5 references to qt6 in files names and recipes, and remove no longer relevant recipes. Task-number: QTBUG-81932 Change-Id: Iab5c6e4a9da2bae6dba9e96f096b5634759deef8 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb')
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
new file mode 100644
index 00000000..d4dce3db
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
@@ -0,0 +1,38 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
+
+LICENSE = "The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=c8b6dd132d52c6e5a545df07a4e3e283"
+
+inherit populate_b2qt_qt6_sdk
+
+TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host"
+TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt6-toolchain-target"