aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-06 07:48:12 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-06 09:25:02 +0300
commit2a64102a2987fce2eb32e390584c8cf703df0905 (patch)
tree76179081bb631861e00243a3e83a183727db071a /meta-boot2qt-distro
parent93cabd64a8f0d10959726177e18599e581ba2251 (diff)
parent780f0729634640d5caa103ee8634a396513fb1f6 (diff)
Merge remote-tracking branch 'origin/sumo' into thud
* origin/sumo: Update automotive sha1s and remove QT_MODULE_BRANCH ogl-runtime: enable viewer coin: use predefined set of target configurations ogl-runtime: skip for unsupported machines raspberrypi: enable ALSA audio fonts: add Thai font (Fonts-TLWG) Move qtlauncher applications root path and style to settings file Update sha1s for automotive 5.12.4 qtapplicationmanager: fix multi-process option coin: update CI build instructions neptune3-ui: Start neptune3 as the root user Add boot2qt-launcher package config file Implement module instructions for coin jetson: Use default KERNEL_ROOTSPEC for jetson boards jetson-tx2: attach bluetooth device meta-qt5: update layer meta-qt5: update layer meta-qt5: update layer meta-qt5: update layer Change-Id: Iae6145f4209676aac03f4094dc51223582bc0fc3
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/conf/distro/include/emulator.conf4
-rw-r--r--meta-boot2qt-distro/conf/distro/include/raspberrypi.inc9
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb1
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb3
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb5
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime/0001-Enable-viewer-for-boot2qt-builds.patch22
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime_git.bbappend32
7 files changed, 73 insertions, 3 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/emulator.conf b/meta-boot2qt-distro/conf/distro/include/emulator.conf
index 619af16f..4e14de29 100644
--- a/meta-boot2qt-distro/conf/distro/include/emulator.conf
+++ b/meta-boot2qt-distro/conf/distro/include/emulator.conf
@@ -35,6 +35,10 @@ MACHINE_EXTRA_RRECOMMENDS += "\
kernel-module-snd-intel8x0 \
"
+# ogl-runtime uses egl directly
+OGL_RUNTIME = ""
+OGL_RUNTIME_DEV = ""
+
PREFERRED_PROVIDER_virtual/egl = "qtglesstream-dummy-client"
PREFERRED_PROVIDER_virtual/libgles2 = "qtglesstream-dummy-client"
diff --git a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
index 2eaf9065..263c4b89 100644
--- a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
+++ b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
@@ -38,6 +38,10 @@ MACHINE_EXTRA_INSTALL += "\
omxplayer \
"
+# ogl-runtime depends on gles3
+OGL_RUNTIME = ""
+OGL_RUNTIME_DEV = ""
+
KERNEL_MODULE_AUTOLOAD += "snd-bcm2835 bcm2835-v4l2"
KERNEL_MODULE_PROBECONF += "bcm2835-v4l2"
module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1"
@@ -45,6 +49,11 @@ module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1"
# video camera support
VIDEO_CAMERA = "1"
+RPI_EXTRA_CONFIG = "# \
+Enable the onboard ALSA audio \n\
+dtparam=audio=on \n\
+"
+
MACHINE_FEATURES += "pitft"
MACHINE_GSTREAMER_1_0_PLUGIN += "gstreamer1.0-omx"
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
index 3dbda886..2424b9a0 100644
--- a/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bb
@@ -45,6 +45,7 @@ RDEPENDS_${PN} = "\
ttf-dejavu-common \
ttf-dejavu-sans \
ttf-freefont-mono \
+ ttf-tlwg \
otf-noto \
dbus-session-init \
tzdata \
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index e661154e..48947c42 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -37,6 +37,7 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
MACHINE_EXTRA_INSTALL_SDK ?= ""
+OGL_RUNTIME_DEV ?= "ogl-runtime-dev"
GCC-SANITIZERS ?= "gcc-sanitizers"
GCC-SANITIZERS_mipsarch = ""
GCC-SANITIZERS_libc-musl = ""
@@ -46,8 +47,8 @@ RDEPENDS_${PN} += " \
packagegroup-core-standalone-sdk-target \
${GCC-SANITIZERS} \
\
+ ${OGL_RUNTIME_DEV} \
qt3d-dev \
- qt3d-runtime-dev \
qtbase-dev \
qtbase-staticdev \
qtbase-doc \
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index 95086995..2bf80ad3 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -34,10 +34,11 @@ inherit packagegroup
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
+OGL_RUNTIME ?= "ogl-runtime ogl-runtime-tools"
+
RDEPENDS_${PN} += " \
+ ${OGL_RUNTIME} \
qt3d \
- qt3d-runtime \
- qt3d-runtime-tools \
qtbase \
qtcharts \
qtconnectivity \
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime/0001-Enable-viewer-for-boot2qt-builds.patch b/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime/0001-Enable-viewer-for-boot2qt-builds.patch
new file mode 100644
index 00000000..0797e2d1
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime/0001-Enable-viewer-for-boot2qt-builds.patch
@@ -0,0 +1,22 @@
+From 86fa457545a2f750a34984106e5863a46dd5ea1e Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Mon, 5 Aug 2019 08:58:14 +0300
+Subject: [PATCH] Enable viewer for boot2qt builds
+
+---
+ tools/tools.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/tools.pro b/tools/tools.pro
+index 7c62eae..a836fe6 100644
+--- a/tools/tools.pro
++++ b/tools/tools.pro
+@@ -1,7 +1,7 @@
+ TEMPLATE = subdirs
+ CONFIG += ordered
+
+-!boot2qt:!integrity:!qnx {
++!integrity:!qnx {
+ SUBDIRS += viewer
+ }
+
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime_git.bbappend
new file mode 100644
index 00000000..4f410ebf
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt5/ogl-runtime_git.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-Enable-viewer-for-boot2qt-builds.patch"