aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-10-01 14:16:05 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-10-11 23:49:02 +0300
commit4530e45c59ee89b033e3f25a45e12a1576500c9b (patch)
tree165dafe4c6eaece06abfcf83519517b30ea44658 /meta-boot2qt-distro
parent73ea923d79104ed207846406869b15366db11126 (diff)
meta-qt5: update layer
Update to first snapshot of Qt 5.13.2 branch. Changelog: 79a0e93 qt5: update submodules 9c73608 Use pcre packages by default ff4e4b2 qtbase-native: disable vulkan support Task-number: QTBUG-78897 Change-Id: I20d247f7ed1c55e93b628fefb7a89713e667cebc Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend10
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch25
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Workaround-for-finding-the-host-architecture-detecti.patch51
3 files changed, 4 insertions, 82 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index d0d1685c..a464a22f 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2018 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -41,10 +41,8 @@ PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
fakeroot do_generate_qt_environment_file_mingw32() {
}
-SRC_URI_append_mingw32 = "\
- file://0001-disable-qt_random_cpu.patch \
- file://0002-Workaround-for-finding-the-host-architecture-detecti.patch \
- "
-
# qdatetime.cpp: error: 'localtime_r' was not declared in this scope
QT_CONFIG_FLAGS_append_mingw32 = " -D_POSIX_C_SOURCE"
+
+# workaround for QTBUG-64707
+QT_CONFIG_FLAGS_append_mingw32 = " -no-feature-rdrnd"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
deleted file mode 100644
index 26c78381..00000000
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 655618933b78f53bb4338c8b7e3109da780ad3c6 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Thu, 23 Nov 2017 11:28:47 +0200
-Subject: [PATCH] disable qt_random_cpu
-
-The code caused internal compiler error when compiling for mingw32
-
-Change-Id: Ieba798a9599a6d683c6630c6cd3731b2b909b628
----
- src/corelib/global/qrandom.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
-index 6769190..c1a775a 100644
---- a/src/corelib/global/qrandom.cpp
-+++ b/src/corelib/global/qrandom.cpp
-@@ -92,7 +92,7 @@ DECLSPEC_IMPORT BOOLEAN WINAPI SystemFunction036(PVOID RandomBuffer, ULONG Rando
-
- QT_BEGIN_NAMESPACE
-
--#if defined(Q_PROCESSOR_X86) && QT_COMPILER_SUPPORTS_HERE(RDRND)
-+#if 0
- static qsizetype qt_random_cpu(void *buffer, qsizetype count) Q_DECL_NOTHROW;
-
- # ifdef Q_PROCESSOR_X86_64
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Workaround-for-finding-the-host-architecture-detecti.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Workaround-for-finding-the-host-architecture-detecti.patch
deleted file mode 100644
index 1ecab120..00000000
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0002-Workaround-for-finding-the-host-architecture-detecti.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 6ef88256cfd9198232d3407dffad83912a87b6af Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Thu, 1 Aug 2019 15:18:47 +0300
-Subject: [PATCH] Workaround for finding the host architecture detection binary
-
-Workaround for QTBUG-77286 which causes mingw32 builds to fail.
-
-Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
----
- configure.pri | 2 +-
- mkspecs/win32-g++/qmake.conf | 8 ++++----
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/configure.pri b/configure.pri
-index 7b8dee0953..eedadb802c 100644
---- a/configure.pri
-+++ b/configure.pri
-@@ -286,7 +286,7 @@ defineTest(qtConfTest_architecture) {
- !qtConfTest_compile($${1}): \
- error("Could not determine $$eval($${1}.label). See config.log for details.")
-
-- host = $$eval($${1}.host)
-+ #host = $$eval($${1}.host)
- isEmpty(host): host = false
- file_prefix =
- exts = -
-diff --git a/mkspecs/win32-g++/qmake.conf b/mkspecs/win32-g++/qmake.conf
-index 5de482f23b..63e41d34ed 100644
---- a/mkspecs/win32-g++/qmake.conf
-+++ b/mkspecs/win32-g++/qmake.conf
-@@ -12,16 +12,16 @@ include(../common/windows-desktop.conf)
-
- # modifications to g++-win32.conf
-
--QMAKE_CC = $${CROSS_COMPILE}gcc
-+QMAKE_CC = i686-w64-mingw32-gcc
- QMAKE_CFLAGS += -fno-keep-inline-dllexport
- QMAKE_CFLAGS_WARN_ON += -Wextra
-
--QMAKE_CXX = $${CROSS_COMPILE}g++
-+QMAKE_CXX = i686-w64-mingw32-g++
- QMAKE_CXXFLAGS += -fno-keep-inline-dllexport
- QMAKE_CXXFLAGS_WARN_ON = $$QMAKE_CFLAGS_WARN_ON
-
--QMAKE_LINK = $${CROSS_COMPILE}g++
--QMAKE_LINK_C = $${CROSS_COMPILE}gcc
-+QMAKE_LINK = i686-w64-mingw32-g++
-+QMAKE_LINK_C = i686-w64-mingw32-gcc
-
- QMAKE_CFLAGS_LTCG = -flto
- QMAKE_CXXFLAGS_LTCG = $$QMAKE_CFLAGS_LTCG