aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-05-30 09:24:56 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-06-04 14:06:43 +0300
commitb83487e129aa4629929e879f0c7bd1d4c067ed0e (patch)
tree9a85d86305bcb621a9c4acf8dba49bad185319ea /meta-boot2qt-distro
parenta0986da928cce63ce2e400d809bf4486f46e9b64 (diff)
Add QtSafeRenderer 1.1
Add recipe for the QtSafeRenderer and include it in the automotive image and toolchain. The sources are in a private git repository, so it's included in the build only if we know that we have access to those (internal-build) or user has explicitly enabled it in the local.conf (DISTRO_FEATURES_BACKFILL). The recipe also knows how to use the sources from a Qt online SDK intallation if the variable (QT_SDK_PATH) is setup correctly. Neptune3 is enabled to use QSR if that is available. Task-number: AUTOSUITE-1009 Change-Id: I2efc68a598f1e83324de40f4f0cccce9615045f7 Reviewed-by: Nikolay Zamotaev <nzamotaev@luxoft.com> Reviewed-by: Jani Launonen <jani.launonen@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/conf/local.conf.sample6
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb2
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb2
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb3
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend2
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend2
6 files changed, 16 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/conf/local.conf.sample b/meta-boot2qt-distro/conf/local.conf.sample
index 24c572e4..c6db921f 100644
--- a/meta-boot2qt-distro/conf/local.conf.sample
+++ b/meta-boot2qt-distro/conf/local.conf.sample
@@ -284,6 +284,12 @@ INHERIT += "internal-build"
ACCEPT_FSL_EULA = "1"
LICENSE_FLAGS_WHITELIST = "commercial"
+# Path to the Qt online SDK installation, used for sources that are available only from
+# the online installer.
QT_SDK_PATH = ""
+# If you have access to QtSafeRenderer sources, either from git or QtSDK,
+# you can enable it by uncommenting following line
+#DISTRO_FEATURES_BACKFILL_append = " qtsaferenderer"
+
include conf/distro/include/${MACHINE}.pre.inc
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
index 8c4adaae..383ad07e 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-automotive-qt5-toolchain-host.bb
@@ -38,3 +38,5 @@ RDEPENDS_${PN} += "\
nativesdk-qtapplicationmanager-tools \
nativesdk-qtivi-tools \
"
+
+RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'qtsaferenderer', 'nativesdk-qtsaferenderer-tools', '', d)}"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index 078763ae..884a5acf 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -44,3 +44,5 @@ RDEPENDS_${PN} += " \
qmllive \
qdb \
"
+
+RDEPENDS_${PN} += "${@bb.utils.filter('DISTRO_FEATURES', 'qtsaferenderer', d)}"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb
index 3b64622f..efdb6e63 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automotive-qt5-toolchain-target.bb
@@ -41,3 +41,6 @@ RDEPENDS_${PN} += " \
qtapplicationmanager-dev \
qtapplicationmanager-staticdev \
"
+
+RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'qtsaferenderer', \
+ 'qtsaferenderer-dev qtsaferenderer-staticdev', '', d)}"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index 1296c18b..8372fbc8 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -33,7 +33,7 @@ SRC_URI += "\
file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
"
-PACKAGECONFIG += "openssl"
+PACKAGECONFIG += "openssl gui imageformats"
PACKAGECONFIG_remove_mingw32 += "openssl"
PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
index 821c6d3e..eecfa5a6 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
@@ -29,6 +29,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
+PACKAGECONFIG += "gui imageformats"
+
SRC_URI += "\
file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
"