aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-22 16:30:12 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-09-06 07:45:27 +0300
commit312f8942223e2ab1592969abb65aefc8c2abde58 (patch)
tree4def42420e28e093fcbe8a066e77dc496b2450c9 /meta-raspberrypi-extras
parentafafbcc3fa2b959b3999e52b9a3bbdbd77b5715c (diff)
Add recipe for default Qt environment variables
Move existing Qt environment variables from appcontroller conf to a separate component. Appcontroller is configured to use the same file, and it can also be used without appcontroller from a systemd service to get working Qt environment. Task-number: AUTOSUITE-1141 Change-Id: I588769a3bba036ab9f90e0292ab17e7d3f040f80 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes-qt/boot2qt-addons/default-qt-envs.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/meta-raspberrypi-extras/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
new file mode 100644
index 00000000..2b371506
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_configure_append() {
+ echo "QT_QPA_EGLFS_FORCE888=1" >> ${WORKDIR}/defaults
+}