aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2017-06-23 13:39:13 +0200
committerMichal Klocek <michal.klocek@qt.io>2017-06-26 11:41:21 +0000
commit4201f572968d6864322d40ef8e961ad1959108da (patch)
tree529ec075971c3d6acdffc974c3622053c823d901 /meta-raspberrypi-extras
parentd1f280438d2135a3dff946b4ec4cdf1c0935382d (diff)
Enable sound on raspberrypi
Currently there is no sound when playing videos. Change-Id: I8240b4ecdcc4966869751f97cde6168515d7c4d9 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 00000000..1b8e44e4
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_deploy_append() {
+ echo "dtparam=audio=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}