aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-04 12:28:31 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-05 10:30:07 +0000
commit88018bbd9bd18425a876505a13e5e32b79d7f33c (patch)
tree567058336bc9ef5893548e2c7af7bb171899cb9d /meta-raspberrypi-extras
parentdf4676ca212935e7ba57c83cdca41625a55cd8d6 (diff)
RPI: use latest revision of meta-raspberrypi
Adds support for RPi Zero and the 7" touch display Change-Id: I4ac5f2ce9e2ac8aa300331f48abaaf4249c70cee Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/conf/layer.conf33
-rw-r--r--meta-raspberrypi-extras/recipes/linux/linux-raspberrypi/ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch171
-rw-r--r--meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_3.12.%.bbappend27
3 files changed, 0 insertions, 231 deletions
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf
deleted file mode 100644
index 0ac91aa1..00000000
--- a/meta-raspberrypi-extras/conf/layer.conf
+++ /dev/null
@@ -1,33 +0,0 @@
-#############################################################################
-##
-## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
-##
-## This file is part of the Qt Enterprise Embedded Scripts of the Qt
-## framework.
-##
-## $QT_BEGIN_LICENSE$
-## Commercial License Usage Only
-## Licensees holding valid commercial Qt license agreements with Digia
-## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
-## may use this file in accordance with the terms contained in said license
-## agreement.
-##
-## For further information use the contact form at
-## http://www.qt.io/contact-us.
-##
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-# We have a conf and classes directory, append to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
- ${LAYERDIR}/recipes*/*/*.bbappend \
- "
-
-BBFILE_COLLECTIONS += "b2qt_rpi"
-BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/"
-BBFILE_PRIORITY_b2qt_rpi = "20"
diff --git a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi/ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi/ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch
deleted file mode 100644
index 4f2a45a7..00000000
--- a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi/ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-From 7495f3742dda97612a77d92fa62f85cb7591ab14 Mon Sep 17 00:00:00 2001
-From: Will Deacon <will.deacon@arm.com>
-Date: Thu, 26 Sep 2013 12:36:36 +0100
-Subject: [PATCH] ARM: perf: wire up perf_regs and unwind support for ARM
-
-This patch hooks in the perf_regs and libunwind code for ARM.
-
-Cc: Jean Pihet <jean.pihet@linaro.org>
-Signed-off-by: Will Deacon <will.deacon@arm.com>
----
- tools/perf/arch/arm/Makefile | 3 ++
- tools/perf/arch/arm/include/perf_regs.h | 54 +++++++++++++++++++++++++++++++++
- tools/perf/arch/arm/util/unwind.c | 48 +++++++++++++++++++++++++++++
- tools/perf/config/Makefile | 7 +++--
- 4 files changed, 110 insertions(+), 2 deletions(-)
- create mode 100644 tools/perf/arch/arm/include/perf_regs.h
- create mode 100644 tools/perf/arch/arm/util/unwind.c
-
-diff --git a/tools/perf/arch/arm/Makefile b/tools/perf/arch/arm/Makefile
-index 15130b5..fe9b61e 100644
---- a/tools/perf/arch/arm/Makefile
-+++ b/tools/perf/arch/arm/Makefile
-@@ -2,3 +2,6 @@ ifndef NO_DWARF
- PERF_HAVE_DWARF_REGS := 1
- LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/dwarf-regs.o
- endif
-+ifndef NO_LIBUNWIND
-+LIB_OBJS += $(OUTPUT)arch/$(ARCH)/util/unwind.o
-+endif
-diff --git a/tools/perf/arch/arm/include/perf_regs.h b/tools/perf/arch/arm/include/perf_regs.h
-new file mode 100644
-index 0000000..2a1cfde
---- /dev/null
-+++ b/tools/perf/arch/arm/include/perf_regs.h
-@@ -0,0 +1,54 @@
-+#ifndef ARCH_PERF_REGS_H
-+#define ARCH_PERF_REGS_H
-+
-+#include <stdlib.h>
-+#include "../../util/types.h"
-+#include <asm/perf_regs.h>
-+
-+#define PERF_REGS_MASK ((1ULL << PERF_REG_ARM_MAX) - 1)
-+#define PERF_REG_IP PERF_REG_ARM_PC
-+#define PERF_REG_SP PERF_REG_ARM_SP
-+
-+static inline const char *perf_reg_name(int id)
-+{
-+ switch (id) {
-+ case PERF_REG_ARM_R0:
-+ return "r0";
-+ case PERF_REG_ARM_R1:
-+ return "r1";
-+ case PERF_REG_ARM_R2:
-+ return "r2";
-+ case PERF_REG_ARM_R3:
-+ return "r3";
-+ case PERF_REG_ARM_R4:
-+ return "r4";
-+ case PERF_REG_ARM_R5:
-+ return "r5";
-+ case PERF_REG_ARM_R6:
-+ return "r6";
-+ case PERF_REG_ARM_R7:
-+ return "r7";
-+ case PERF_REG_ARM_R8:
-+ return "r8";
-+ case PERF_REG_ARM_R9:
-+ return "r9";
-+ case PERF_REG_ARM_R10:
-+ return "r10";
-+ case PERF_REG_ARM_FP:
-+ return "fp";
-+ case PERF_REG_ARM_IP:
-+ return "ip";
-+ case PERF_REG_ARM_SP:
-+ return "sp";
-+ case PERF_REG_ARM_LR:
-+ return "lr";
-+ case PERF_REG_ARM_PC:
-+ return "pc";
-+ default:
-+ return NULL;
-+ }
-+
-+ return NULL;
-+}
-+
-+#endif /* ARCH_PERF_REGS_H */
-diff --git a/tools/perf/arch/arm/util/unwind.c b/tools/perf/arch/arm/util/unwind.c
-new file mode 100644
-index 0000000..da3dc95
---- /dev/null
-+++ b/tools/perf/arch/arm/util/unwind.c
-@@ -0,0 +1,48 @@
-+
-+#include <errno.h>
-+#include <libunwind.h>
-+#include "perf_regs.h"
-+#include "../../util/unwind.h"
-+
-+int unwind__arch_reg_id(int regnum)
-+{
-+ switch (regnum) {
-+ case UNW_ARM_R0:
-+ return PERF_REG_ARM_R0;
-+ case UNW_ARM_R1:
-+ return PERF_REG_ARM_R1;
-+ case UNW_ARM_R2:
-+ return PERF_REG_ARM_R2;
-+ case UNW_ARM_R3:
-+ return PERF_REG_ARM_R3;
-+ case UNW_ARM_R4:
-+ return PERF_REG_ARM_R4;
-+ case UNW_ARM_R5:
-+ return PERF_REG_ARM_R5;
-+ case UNW_ARM_R6:
-+ return PERF_REG_ARM_R6;
-+ case UNW_ARM_R7:
-+ return PERF_REG_ARM_R7;
-+ case UNW_ARM_R8:
-+ return PERF_REG_ARM_R8;
-+ case UNW_ARM_R9:
-+ return PERF_REG_ARM_R9;
-+ case UNW_ARM_R10:
-+ return PERF_REG_ARM_R10;
-+ case UNW_ARM_R11:
-+ return PERF_REG_ARM_FP;
-+ case UNW_ARM_R12:
-+ return PERF_REG_ARM_IP;
-+ case UNW_ARM_R13:
-+ return PERF_REG_ARM_SP;
-+ case UNW_ARM_R14:
-+ return PERF_REG_ARM_LR;
-+ case UNW_ARM_R15:
-+ return PERF_REG_ARM_PC;
-+ default:
-+ pr_err("unwind: invalid reg id %d\n", regnum);
-+ return -EINVAL;
-+ }
-+
-+ return -EINVAL;
-+}
-diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
-index 5f6f9b3..4796ce5 100644
---- a/tools/perf/config/Makefile
-+++ b/tools/perf/config/Makefile
-@@ -29,6 +29,10 @@ ifeq ($(ARCH),x86_64)
- NO_PERF_REGS := 0
- LIBUNWIND_LIBS = -lunwind -lunwind-x86_64
- endif
-+ifeq ($(ARCH),arm)
-+ NO_PERF_REGS := 0
-+ LIBUNWIND_LIBS = -lunwind -lunwind-arm
-+endif
-
- ifeq ($(NO_PERF_REGS),0)
- CFLAGS += -DHAVE_PERF_REGS
-@@ -208,8 +212,7 @@ ifeq ($(call try-cc,$(SOURCE_ELF_MMAP),$(FLAGS_LIBELF),-DLIBELF_MMAP),y)
- endif # try-cc
- endif # NO_LIBELF
-
--# There's only x86 (both 32 and 64) support for CFI unwind so far
--ifneq ($(ARCH),x86)
-+ifeq ($(LIBUNWIND_LIBS),)
- NO_LIBUNWIND := 1
- endif
-
---
-1.9.1
-
diff --git a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_3.12.%.bbappend b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_3.12.%.bbappend
deleted file mode 100644
index 94b2ab10..00000000
--- a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_3.12.%.bbappend
+++ /dev/null
@@ -1,27 +0,0 @@
-#############################################################################
-##
-## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
-##
-## This file is part of the Qt Enterprise Embedded Scripts of the Qt
-## framework.
-##
-## $QT_BEGIN_LICENSE$
-## Commercial License Usage Only
-## Licensees holding valid commercial Qt license agreements with Digia
-## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
-## may use this file in accordance with the terms contained in said license
-## agreement.
-##
-## For further information use the contact form at
-## http://www.qt.io/contact-us.
-##
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${THISDIR}/../../../recipes/linux/linux:"
-SRC_URI += "\
- file://ARM-perf-add-support-for-perf-registers-API.diff \
- file://ARM-perf-wire-up-perf_regs-and-unwind-support-for-AR.patch \
- "