aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-03-31 11:01:04 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-12 14:47:11 +0300
commitae4b6421c0bb4771e2cedfcdadd44c04dc8e93f5 (patch)
treeacaecd3b089b341f87dd27384bb800c9b497148d /meta-raspberrypi-extras
parent5fcb893d078d718318ca94bf7f284ef35355c152 (diff)
Build Qt5 and all addons
Use meta-qt5 layer to build Qt5, commercial addons and b2qt addons. Create new image and toolchain recipes with Qt5 content, so that the existing image and toolchain remain as-is without Qt5. Currently support only for imx6 targets. Change-Id: I398750dd1a62c6ff8ea216cfe364da273d8e9a77 Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend b/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
new file mode 100644
index 00000000..92e08b74
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
@@ -0,0 +1,42 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+do_configure_prepend_rpi() {
+ sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
+ cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
+RPI_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
+
+QMAKE_INCDIR_EGL = \$\$[QT_SYSROOT]/usr/include/interface/vcos/pthreads \
+ \$\$[QT_SYSROOT]/usr/include/interface/vmcs_host/linux
+QMAKE_INCDIR_OPENGL_ES2 = \$\${QMAKE_INCDIR_EGL}
+
+QMAKE_LIBS_EGL = -lEGL -lGLESv2
+QMAKE_CFLAGS += \$\$RPI_CFLAGS
+QMAKE_CXXFLAGS += \$\$RPI_CFLAGS
+
+EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/../devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp
+EGLFS_PLATFORM_HOOKS_LIBS = -lbcm_host
+
+load(qt_config)
+
+EOF
+}