aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-03-21 16:47:50 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-03-31 10:27:47 +0000
commitbd776cb94282d10ece0c31762c909ae56f86b2c9 (patch)
tree37d84afe0c7b4b68cf7248224635bb41991f1c81 /meta-raspberrypi-extras
parent524b7e183095d120d8168472c0539711f29cd124 (diff)
Use more of the default distro features from poky
Remove unwanted features instead of overwriting full set. This brings e.g., wayland support by default to all targets. Add fixes for building weston on TI and RPi targets Change-Id: If3bd23a289e34ebe9656a03494e65ba7d8c843b0 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/conf/layer.conf40
-rw-r--r--meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend31
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/conf/layer.conf b/meta-raspberrypi-extras/conf/layer.conf
new file mode 100644
index 00000000..9e64b878
--- /dev/null
+++ b/meta-raspberrypi-extras/conf/layer.conf
@@ -0,0 +1,40 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "b2qt_rpi"
+BBFILE_PATTERN_b2qt_rpi := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt_rpi = "20"
diff --git a/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend b/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend
new file mode 100644
index 00000000..25ec2642
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/wayland/weston_%.bbappend
@@ -0,0 +1,31 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# from https://www.mail-archive.com/yocto@yoctoproject.org/msg33193.html
+PACKAGECONFIG_remove_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'fbdev', 'kms', d)}"