aboutsummaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi-extras
diff options
context:
space:
mode:
authorEirik Aavitsland <eirik.aavitsland@theqtcompany.com>2015-05-13 15:44:02 +0200
committerEirik Aavitsland <eirik.aavitsland@theqtcompany.com>2015-05-28 14:13:39 +0300
commite8067960ac419c9a47824fa996283d31faa9c309 (patch)
tree2527ba7b8be52be88a2e45dd785100156a1930e5 /meta-raspberrypi-extras
parent10c6c4ef744ca122f976be1d4f68713cafc01730 (diff)
Toolchain: add static device mkspec, suitable for Qt Creator
The linux-oe-g++ mkspec used by meta-qt5 depends on the user sourcing the toolchain environment-setup script, which modifies the PATH and sets a long range of environment variables. That is not a "best practice" way of use Qt, and does not allow smooth integration of the toolchain into Qt Creator. Here, we instead create a static mkspec for the toolchain: devices/linux-oe-generic-g++. The toolchain recipe will will the qdevice.pri file with the required compiler flags etc. for the target. Additionally, we introduce an extra .pri file for device-specific settings, so they can be shared between the two mkspecs. Change-Id: Ie5a019524ba6cdddffb71b0c7c28861ddba17fbd Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-raspberrypi-extras')
-rw-r--r--meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend42
1 files changed, 0 insertions, 42 deletions
diff --git a/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend b/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
deleted file mode 100644
index 92e08b74..00000000
--- a/meta-raspberrypi-extras/recipes/qt5/qtbase_%.bbappend
+++ /dev/null
@@ -1,42 +0,0 @@
-#############################################################################
-##
-## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
-##
-## This file is part of the Qt Enterprise Embedded Scripts of the Qt
-## framework.
-##
-## $QT_BEGIN_LICENSE$
-## Commercial License Usage Only
-## Licensees holding valid commercial Qt license agreements with Digia
-## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
-## may use this file in accordance with the terms contained in said license
-## agreement.
-##
-## For further information use the contact form at
-## http://www.qt.io/contact-us.
-##
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-do_configure_prepend_rpi() {
- sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
- cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
-RPI_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
-
-QMAKE_INCDIR_EGL = \$\$[QT_SYSROOT]/usr/include/interface/vcos/pthreads \
- \$\$[QT_SYSROOT]/usr/include/interface/vmcs_host/linux
-QMAKE_INCDIR_OPENGL_ES2 = \$\${QMAKE_INCDIR_EGL}
-
-QMAKE_LIBS_EGL = -lEGL -lGLESv2
-QMAKE_CFLAGS += \$\$RPI_CFLAGS
-QMAKE_CXXFLAGS += \$\$RPI_CFLAGS
-
-EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/../devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp
-EGLFS_PLATFORM_HOOKS_LIBS = -lbcm_host
-
-load(qt_config)
-
-EOF
-}