aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb')
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb b/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb
new file mode 100644
index 00000000..d761263e
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb
@@ -0,0 +1,42 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += " python3-setuptools-scm \
+ python3-setuptools-scm-native \
+ "
+
+PYPI_PACKAGE = "path.py"
+inherit pypi setuptools3
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+SRC_URI[md5sum] = "307098b1827af6031687edb49ce2c39c"
+SRC_URI[sha256sum] = "9f2169633403aa0423f6ec000e8701dd1819526c62465f5043952f92527fea0f"
+
+BBCLASSEXTEND = "nativesdk native"