aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb
new file mode 100644
index 00000000..7c232aeb
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demo-ebike-datacollector_git.bb
@@ -0,0 +1,51 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "Boot to Qt Demo - E-Bike DataCollector"
+LICENSE = "(LGPL-3.0 | GPL-2.0+) | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
+
+require boot2qt-demo.inc
+
+S = "${WORKDIR}/git/basicsuite/datacollector"
+
+DEPENDS += "qtbase"
+
+SRC_URI += " \
+ file://ebikedata.service \
+ "
+
+do_install_append() {
+ install -m 0755 -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/ebikedata.service ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN} = "ebikedata.service"
+
+inherit systemd