aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-imx_3.10.17.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-imx_3.10.17.bbappend')
-rw-r--r--recipes/linux/linux-imx_3.10.17.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/linux/linux-imx_3.10.17.bbappend b/recipes/linux/linux-imx_3.10.17.bbappend
new file mode 100644
index 00000000..082c4318
--- /dev/null
+++ b/recipes/linux/linux-imx_3.10.17.bbappend
@@ -0,0 +1,32 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+do_configure_prepend() {
+ # FunctionFS for adb
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+
+ # Enable USB serial support
+ echo "CONFIG_USB_SERIAL=m" >> ${WORKDIR}/defconfig
+ echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${WORKDIR}/defconfig
+ echo "CONFIG_USB_SERIAL_PL2303=m" >> ${WORKDIR}/defconfig
+}