summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2019-07-02 15:19:09 -0500
committerJoshua Watt <JPEWhacker@gmail.com>2019-07-02 15:19:09 -0500
commit1d466f68a08d2251da6c46cd788bf33cc5096f4a (patch)
tree8acf817231bb56475a3dd3c7cd48191490f7b1af
parentd17724b0eac76792a49e56213cba74e32edba48f (diff)
bzip2: Update to 1.0.7
Updates bzip2 to version 1.0.7 to match master in oe-core. The patch to change the path separator was properly upstreamed and hopefully will no longer be necessary going forward. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-extended/bzip2/bzip2/0001-Fix-include-path-separator.patch33
-rw-r--r--recipes-extended/bzip2/bzip2/fix.patch13
-rw-r--r--recipes-extended/bzip2/bzip2_1.0.6.bbappend4
-rw-r--r--recipes-extended/bzip2/bzip2_1.0.7.bbappend4
4 files changed, 37 insertions, 17 deletions
diff --git a/recipes-extended/bzip2/bzip2/0001-Fix-include-path-separator.patch b/recipes-extended/bzip2/bzip2/0001-Fix-include-path-separator.patch
new file mode 100644
index 0000000..4c43b7a
--- /dev/null
+++ b/recipes-extended/bzip2/bzip2/0001-Fix-include-path-separator.patch
@@ -0,0 +1,33 @@
+From 84c8769b52c63cce8a8a413e5fcbad1a65681d46 Mon Sep 17 00:00:00 2001
+From: Joshua Watt <JPEW.hacker@gmail.com>
+Date: Tue, 2 Jul 2019 13:06:30 -0500
+Subject: [PATCH] Fix include path separator
+
+Changes the include path separator for Windows builds to use "/" instead
+of "\". Windows has no problems with using a forward slash as a path
+separator, but using a backslash causes problems when attempting to
+cross compile for other platforms (for example, when trying to cross
+compile for MinGW from Linux).
+
+Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
+Upstream-Status: Submitted [https://sourceware.org/ml/bzip2-devel/2019-q3/msg00004.html]
+---
+ bzip2.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bzip2.c b/bzip2.c
+index e362c65..be3b3be 100644
+--- a/bzip2.c
++++ b/bzip2.c
+@@ -128,7 +128,7 @@
+ #if BZ_LCCWIN32
+ # include <io.h>
+ # include <fcntl.h>
+-# include <sys\stat.h>
++# include <sys/stat.h>
+
+ # define NORETURN /**/
+ # define PATH_SEP '\\'
+--
+2.21.0
+
diff --git a/recipes-extended/bzip2/bzip2/fix.patch b/recipes-extended/bzip2/bzip2/fix.patch
deleted file mode 100644
index a366a5d..0000000
--- a/recipes-extended/bzip2/bzip2/fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: bzip2-1.0.6/bzip2.c
-===================================================================
---- bzip2-1.0.6.orig/bzip2.c 2010-09-10 23:04:53.000000000 +0000
-+++ bzip2-1.0.6/bzip2.c 2013-08-13 10:30:15.596120522 +0000
-@@ -128,7 +128,7 @@
- #if BZ_LCCWIN32
- # include <io.h>
- # include <fcntl.h>
--# include <sys\stat.h>
-+# include <sys/stat.h>
-
- # define NORETURN /**/
- # define PATH_SEP '\\'
diff --git a/recipes-extended/bzip2/bzip2_1.0.6.bbappend b/recipes-extended/bzip2/bzip2_1.0.6.bbappend
deleted file mode 100644
index 882147c..0000000
--- a/recipes-extended/bzip2/bzip2_1.0.6.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append_mingw32 = " file://fix.patch" \ No newline at end of file
diff --git a/recipes-extended/bzip2/bzip2_1.0.7.bbappend b/recipes-extended/bzip2/bzip2_1.0.7.bbappend
new file mode 100644
index 0000000..3cc4b01
--- /dev/null
+++ b/recipes-extended/bzip2/bzip2_1.0.7.bbappend
@@ -0,0 +1,4 @@
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_mingw32 = " file://0001-Fix-include-path-separator.patch"