summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2018-11-19 16:24:32 -0600
committerJoshua Watt <JPEWhacker@gmail.com>2018-11-21 11:11:42 -0600
commit7697cefbbd139361c4d3675f0d99104497b9677a (patch)
tree18b915d7591290c4d2eac380c812bf1b43c50f87
parent2ccb4d55e7676452a3138ed8abfce56d1fb26a72 (diff)
mingw-w64-{headers,runtime,winpthreads}: Upgrade 5.0.3 -> 6.0.0
Upgrades the MinGW support recipes to the latest version Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-devtools/mingw-w64/mingw-w64-headers/0001-intrin-impl.h-do-not-define-_xgetbv-for-GCC-8.patch43
-rw-r--r--recipes-devtools/mingw-w64/mingw-w64-headers/epsilon.patch16
-rw-r--r--recipes-devtools/mingw-w64/mingw-w64.inc14
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_6.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb)11
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb)8
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_5.0.3.bb)8
6 files changed, 17 insertions, 83 deletions
diff --git a/recipes-devtools/mingw-w64/mingw-w64-headers/0001-intrin-impl.h-do-not-define-_xgetbv-for-GCC-8.patch b/recipes-devtools/mingw-w64/mingw-w64-headers/0001-intrin-impl.h-do-not-define-_xgetbv-for-GCC-8.patch
deleted file mode 100644
index 366afdc..0000000
--- a/recipes-devtools/mingw-w64/mingw-w64-headers/0001-intrin-impl.h-do-not-define-_xgetbv-for-GCC-8.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 63d69029386701955e8fa10ac14be8d2316faf6f Mon Sep 17 00:00:00 2001
-From: Mateusz <mateuszb@poczta.onet.pl>
-Date: Mon, 22 Jan 2018 20:58:48 +0100
-Subject: [PATCH] intrin-impl.h: do not define _xgetbv for GCC 8
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-GCC 8 from r248028 has defined function _xgetbv and we should
-avoid double definition of this function.
-
-Signed-off-by: Mateusz Brzostek <mateuszb@poczta.onet.pl>
-Signed-off-by: Martin Storsjö <martin@martin.st>
----
- mingw-w64-headers/include/psdk_inc/intrin-impl.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/mingw-w64-headers/include/psdk_inc/intrin-impl.h b/mingw-w64-headers/include/psdk_inc/intrin-impl.h
-index 7da3238b..4990b0ae 100644
---- a/mingw-w64-headers/include/psdk_inc/intrin-impl.h
-+++ b/mingw-w64-headers/include/psdk_inc/intrin-impl.h
-@@ -1405,6 +1405,7 @@ __buildmov(__movsd, unsigned __LONG32, "d")
- #define __INTRINSIC_DEFINED___movsd
- #endif /* __INTRINSIC_PROLOG */
-
-+#if !defined(__GNUC__) || __GNUC__ < 8 /* GCC 8 has already defined _xgetbv */
- /* NOTE: This should be in immintrin.h */
- #if __INTRINSIC_PROLOG(_xgetbv)
- unsigned __int64 _xgetbv(unsigned int);
-@@ -1426,6 +1427,7 @@ unsigned __int64 _xgetbv(unsigned int index)
- }
- #define __INTRINSIC_DEFINED__xgetbv
- #endif /* __INTRINSIC_PROLOG */
-+#endif /* __GNUC__ < 8 */
-
- #endif /* defined(__x86_64__) || defined(_AMD64_) || defined(__i386__) || defined(_X86_) */
-
---
-2.11.0
-
diff --git a/recipes-devtools/mingw-w64/mingw-w64-headers/epsilon.patch b/recipes-devtools/mingw-w64/mingw-w64-headers/epsilon.patch
deleted file mode 100644
index 10213ee..0000000
--- a/recipes-devtools/mingw-w64/mingw-w64-headers/epsilon.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-mpfr 3.1.2 references these symbols and fails if they're not defined.
-
-Index: mingw-w64-headers/crt/float.h
-===================================================================
---- mingw-w64-headers/crt.orig/float.h 2012-07-17 11:03:12.000000000 +0000
-+++ mingw-w64-headers/crt/float.h 2013-08-13 08:23:20.000000000 +0000
-@@ -111,6 +111,9 @@
- #define FLT_ROUNDS 1
-
- #define _FLOAT_H___
-+
-+ #define DBL_EPSILON __DBL_EPSILON__
-+ #define FLT_EPSILON __FLT_EPSILON__
- #endif
- #endif
- #endif
diff --git a/recipes-devtools/mingw-w64/mingw-w64.inc b/recipes-devtools/mingw-w64/mingw-w64.inc
new file mode 100644
index 0000000..8c68bcc
--- /dev/null
+++ b/recipes-devtools/mingw-w64/mingw-w64.inc
@@ -0,0 +1,14 @@
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/mingw-w64-v${PV}/COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
+
+COMPATIBLE_HOST = ".*-mingw.*"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "cf5673f6d689bb5e02863e6284cc3d03"
+SRC_URI[sha256sum] = "805e11101e26d7897fce7d49cbb140d7bac15f3e085a91e0001e80b2adaf48f0"
+
+UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/"
+UPSTREAM_CHECK_REGEX = "mingw-w64-v(?P<pver>(\d+[\.\-_]*)+)\.tar"
+
+
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_6.0.0.bb
index 009e5af..58073d6 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_6.0.0.bb
@@ -1,15 +1,6 @@
DESCRIPTION = "Header files from the MingGW-w64 project"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
-COMPATIBLE_HOST = ".*-mingw.*"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2 \
- file://epsilon.patch \
- file://0001-intrin-impl.h-do-not-define-_xgetbv-for-GCC-8.patch;striplevel=2"
-
-SRC_URI[md5sum] = "5524c20312560cc8683b7d8ee292cb8c"
-SRC_URI[sha256sum] = "2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4"
+require mingw-w64.inc
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers"
B = "${WORKDIR}/build-${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
index 0302334..fc83ca8 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
@@ -1,12 +1,6 @@
DESCRIPTION = "Runtime libraries from MinGW-w64 project"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
-COMPATIBLE_HOST = ".*-mingw.*"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-SRC_URI[md5sum] = "5524c20312560cc8683b7d8ee292cb8c"
-SRC_URI[sha256sum] = "2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4"
+require mingw-w64.inc
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
B = "${WORKDIR}/build-${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_5.0.3.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
index 1308760..b278ad7 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_5.0.3.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
@@ -1,12 +1,6 @@
DESCRIPTION = "Winpthreads runtime libraries from MinGW-w64 project"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://../../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
-COMPATIBLE_HOST = ".*-mingw.*"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-SRC_URI[md5sum] = "5524c20312560cc8683b7d8ee292cb8c"
-SRC_URI[sha256sum] = "2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4"
+require mingw-w64.inc
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-libraries/winpthreads"
B = "${WORKDIR}/build-${TARGET_SYS}"