summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2019-02-20 09:38:38 -0600
committerJoshua Watt <JPEWhacker@gmail.com>2019-02-20 12:20:41 -0600
commit6ae8836b39d925b357934dd73562c319ad6200ac (patch)
tree701cc43fc99f08efecf0ddd7a895fae2af9f3336
parent423433e3d31a32dbb80203c628e808442d440ad1 (diff)
diffutils: Upgrade to 3.7
Upgrade diffutils from 3.6 to 3.7. The upstream made several fixes so the local patches are no longer necessary, but the gnulib-tests need to be dropped since they do not compile properly. Since there are no more local patches, the bbappend can be made to match all versions. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--recipes-extended/diffutils/diffutils/sdiff-no-kill.patch32
-rw-r--r--recipes-extended/diffutils/diffutils_%.bbappend14
-rw-r--r--recipes-extended/diffutils/diffutils_3.6.bbappend18
3 files changed, 14 insertions, 50 deletions
diff --git a/recipes-extended/diffutils/diffutils/sdiff-no-kill.patch b/recipes-extended/diffutils/diffutils/sdiff-no-kill.patch
deleted file mode 100644
index c9fbc24..0000000
--- a/recipes-extended/diffutils/diffutils/sdiff-no-kill.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 56225ecca4f9598c0c9dbd7c46a51dd4816a383f Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Fri, 20 Apr 2018 13:39:15 -0700
-Subject: sdiff: port to mingw
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Problem reported by Ross Burton (Bug#31218).
-* src/sdiff.c (checksigs): Use ‘raise’, not ‘kill’.
----
- src/sdiff.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/sdiff.c b/src/sdiff.c
-index 1b23a0c..b08bc74 100644
---- a/src/sdiff.c
-+++ b/src/sdiff.c
-@@ -805,7 +805,7 @@ checksigs (void)
-
- /* Yield an exit status indicating that a signal was received. */
- untrapsig (s);
-- kill (getpid (), s);
-+ raise (s);
-
- /* That didn't work, so exit with error status. */
- exit (EXIT_TROUBLE);
---
-cgit v1.0-41-gc330
diff --git a/recipes-extended/diffutils/diffutils_%.bbappend b/recipes-extended/diffutils/diffutils_%.bbappend
new file mode 100644
index 0000000..2c54a55
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend_mingw32 := "${THISDIR}/${BPN}:"
+
+# Add some definitions for POSIX signals..
+CFLAGS_append_mingw32 = " -DSIGALRM=14 -DSIGHUP=1 -DSIGQUIT=3 -DSIGPIPE=13 -DSIGTSTP=18 -DSIGSTOP=17 "
+
+do_configure_prepend_mingw32 () {
+ # Remove building of "man" and "gnulib-tests". The tests don't
+ # cross-compile for mingw, but we aren't using them anyway
+ sed -i \
+ -e 's:^SUBDIRS =\(.*\) man\>:SUBDIRS = \1 :g' \
+ -e 's:^SUBDIRS =\(.*\) gnulib-tests\>:SUBDIRS = \1 :g' \
+ ${S}/Makefile.am
+}
+
diff --git a/recipes-extended/diffutils/diffutils_3.6.bbappend b/recipes-extended/diffutils/diffutils_3.6.bbappend
deleted file mode 100644
index f301349..0000000
--- a/recipes-extended/diffutils/diffutils_3.6.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-
-FILESEXTRAPATHS_prepend_mingw32 := "${THISDIR}/${BPN}:"
-
-SRC_URI_remove_mingw32 = "file://0001-explicitly-disable-replacing-getopt.patch"
-SRC_URI_append_mingw32 = " file://sdiff-no-kill.patch"
-
-CACHED_CONFIGUREVARS_append_mingw32 = " ac_cv_header_getopt_h=yes "
-
-# Add some definitions for POSIX signals..
-CFLAGS_append_mingw32 = " -DSIGALRM=14 -DSIGHUP=1 -DSIGQUIT=3 -DSIGPIPE=13 -DSIGTSTP=18 -DSIGSTOP=17 "
-
-do_configure_prepend_mingw32 () {
- # Remove building of "man"
- sed -i -e 's:^SUBDIRS = lib src tests doc man po gnulib-test:SUBDIRS = lib src tests doc po gnulib-test:g' ${S}/Makefile.am
-}
-
-
-