summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit84e3017bf8832a5a85f0646ebcb9488dfb09a6ac (patch)
tree8bcef6567f6cbb256c7caa26bdb2c45d9d933e38
parent6bd8366b04811e8bd8ff5a2325a7269d64d46add (diff)
libgcc: Relocate and package dll's in bindir
Relocate and package the dll's provided by libgcc in bindir. It is convention that on mingw/windows dll files are installed into the bindir, this is done to avoid issues with search paths and allows for execution of binaries without the need to point at a libdir. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-devtools/gcc/libgcc_%.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-devtools/gcc/libgcc_%.bbappend b/recipes-devtools/gcc/libgcc_%.bbappend
index dd95317..2a95d02 100644
--- a/recipes-devtools/gcc/libgcc_%.bbappend
+++ b/recipes-devtools/gcc/libgcc_%.bbappend
@@ -1,2 +1,8 @@
-FILES_${PN}_append_mingw32 = " ${base_libdir}/libgcc*.dll"
+FILES_${PN}_append_mingw32 = " ${bindir}/libgcc*.dll"
FILES_${PN}-dev_append_mingw32 = " ${base_libdir}/libgcc*.a"
+
+do_install_append_mingw32 () {
+ # move the .dll files into bindir
+ install -d ${D}${bindir}
+ mv ${D}${base_libdir}/libgcc*.dll ${D}${bindir}/
+}