summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <[mark.hatle@windriver.com]>2017-08-28 14:23:35 -0700
committerJuro Bystricky <juro.bystricky@intel.com>2017-08-28 14:23:35 -0700
commit52515d8bee445d728d5fe63bfcbca79b5d8ea250 (patch)
tree1c1c973c3a78ce8b6265b519baa3d9101d6fb331
parent5a1fb35dc58f9d1fda0a981b46d0886dcaa435d3 (diff)
Fix Yocto Project compatible errors
Each of the recipes modified fail the YP compatible checking script because they modify the checksum of the package, even when the mingw32 SDK is not enabled. This is corrected by ensuring that each of the settings is only done when the mingw32 override is enabled. The PACKAGECONFIG options are moved to oe-core, as there is no way to specify they should only available in the mingw32 override is enabled. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--recipes-core/gettext/gettext_0.19.%.bbappend6
-rw-r--r--recipes-graphics/libsdl/libsdl_%.bbappend5
-rw-r--r--recipes-support/libgcrypt/libgcrypt_1.8.%.bbappend4
3 files changed, 5 insertions, 10 deletions
diff --git a/recipes-core/gettext/gettext_0.19.%.bbappend b/recipes-core/gettext/gettext_0.19.%.bbappend
index 9835d7b..b33970a 100644
--- a/recipes-core/gettext/gettext_0.19.%.bbappend
+++ b/recipes-core/gettext/gettext_0.19.%.bbappend
@@ -4,14 +4,14 @@ LDFLAGS_prepend_mingw32 = " -lpthread "
CFLAGS_append_mingw32 = " -DLIBXML_STATIC"
EXTRA_OECONF_append_mingw32 = " --enable-threads=windows --enable-static"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " \
+FILESEXTRAPATHS_prepend_mingw32 := "${THISDIR}/${BPN}:"
+SRC_URI_append_mingw32 = " \
file://fix-gl_cv_prog_as_underscore-test.patch \
"
FILES_libgettextlib_mingw32 = "${bindir}/libgettextlib-*.dll"
FILES_libgettextsrc_mingw32 = "${bindir}/libgettextsrc-*.dll"
-PACKAGES =+ "libintl"
+PACKAGES_prepend_mingw32 = "libintl "
FILES_libintl_mingw32 = "${bindir}/libintl*.dll"
diff --git a/recipes-graphics/libsdl/libsdl_%.bbappend b/recipes-graphics/libsdl/libsdl_%.bbappend
index bb65f03..592ace5 100644
--- a/recipes-graphics/libsdl/libsdl_%.bbappend
+++ b/recipes-graphics/libsdl/libsdl_%.bbappend
@@ -1,9 +1,4 @@
# Disable default x11 support
PACKAGECONFIG_class-nativesdk_mingw32 = ""
-# Configs that only apply to Windows/MinGW
-PACKAGECONFIG[stdio-redirect] = "--enable-stdio-redirect,--disable-stdio-redirect"
-PACKAGECONFIG[directx] = "--enable-directx,--disable-directx"
-
FILES_${PN}-bin_mingw32 = "${bindir}/*.exe ${sbindir}/*.exe"
-
diff --git a/recipes-support/libgcrypt/libgcrypt_1.8.%.bbappend b/recipes-support/libgcrypt/libgcrypt_1.8.%.bbappend
index e30e376..3da0f53 100644
--- a/recipes-support/libgcrypt/libgcrypt_1.8.%.bbappend
+++ b/recipes-support/libgcrypt/libgcrypt_1.8.%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append = " \
+FILESEXTRAPATHS_prepend_mingw32 := "${THISDIR}/files:"
+SRC_URI_append_mingw32 = " \
file://configure.ac-Set-mym4_revision-to-0-if-not-a-git-rep.patch \
"