summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-04-14 09:31:37 -0700
committerJuro Bystricky <juro.bystricky@intel.com>2018-04-14 09:46:01 -0700
commita59b119a53aa86be8f240610f1ebcd1e6b9ad71f (patch)
tree6f7f0fe33d8f29aa2b576a0628c39f38e7d4f867
parenteee38fa5f2a376c840878fb818cb1dabd9a45491 (diff)
mingw64: update to 5.0.3
Use the latest mingw64 release to get access to the latest Windows APIs BUILDSDK_CPPFLAGS were emptied from poky.conf, but are needed for mingw build to include correct float.h. (error: '_MCW_DN' undeclared here) Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb)4
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb)9
2 files changed, 9 insertions, 4 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb
index 5cd4e34..3948392 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.3.bb
@@ -7,8 +7,8 @@ COMPATIBLE_HOST = ".*-mingw.*"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2 \
file://epsilon.patch"
-SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15"
-SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2"
+SRC_URI[md5sum] = "5524c20312560cc8683b7d8ee292cb8c"
+SRC_URI[sha256sum] = "2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4"
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers"
B = "${WORKDIR}/build-${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb
index c4292ad..9ac830c 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.3.bb
@@ -5,14 +5,19 @@ LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
COMPATIBLE_HOST = ".*-mingw.*"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15"
-SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2"
+#SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15"
+#SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2"
+
+SRC_URI[md5sum] = "5524c20312560cc8683b7d8ee292cb8c"
+SRC_URI[sha256sum] = "2a601db99ef579b9be69c775218ad956a24a09d7dabc9ff6c5bd60da9ccc9cb4"
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
B = "${WORKDIR}/build-${TARGET_SYS}"
inherit autotools nativesdk
+BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}"
+
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc-initial "