summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commitd21fbaa987b54d8f18232b452e87e4f26bbed7a8 (patch)
treec9690b5141bc5b783c01d11487e6918650c2fadb
parent9b61a110e63c2ae0698bbb50d655793f39507099 (diff)
dtc: Only build libfdt for mingw32
Whilst building libfdt on mingw32 is functional, building dtc for mingw32 is not. This is due to dtc relying on certain POSIX functions as well as not handling the MSVCRT printf formatting. This change enables building and installing libfdt only for mingw32, disabling the build of device-tree-compiler itself. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-core/dtc/dtc_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-core/dtc/dtc_%.bbappend b/recipes-core/dtc/dtc_%.bbappend
new file mode 100644
index 0000000..1406937
--- /dev/null
+++ b/recipes-core/dtc/dtc_%.bbappend
@@ -0,0 +1,16 @@
+
+do_configure_append_mingw32 () {
+ # don't try to build the other dtc components when installing libs
+ sed -i 's/install-lib: all/install-lib: libfdt/g' ${S}/Makefile
+}
+
+do_compile_mingw32 () {
+ oe_runmake libfdt
+}
+
+do_install_mingw32 () {
+ oe_runmake install-lib install-includes
+}
+
+RDEPENDS_${PN}-misc_remove_mingw32 = "bash"
+