summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit0234c2291ad35b637821efda80f1ba5e77c7bf26 (patch)
treece8675d50a03d46772c876e34c8b502064bf2fcc
parentc367e072565f276eee0b2b8a6410178f01f68758 (diff)
glib-2.0: Handle packaging .dll and .exe files for mingw32
Handle the packaging of .dll files into the ${PN} package, also package only certain .exe files into the ${PN} and others into the ${PN}-utils packages. This is required due to the mingw/windows convention where .dll's are shipped in the bindir. Move the packaging of *.def into the ${PN}-dev package, it is only used during development/compilation. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-core/glib-2.0/glib-2.0_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-core/glib-2.0/glib-2.0_%.bbappend b/recipes-core/glib-2.0/glib-2.0_%.bbappend
index 5683364..2accd7a 100644
--- a/recipes-core/glib-2.0/glib-2.0_%.bbappend
+++ b/recipes-core/glib-2.0/glib-2.0_%.bbappend
@@ -1,5 +1,5 @@
EXTRA_OECONF_mingw32 = "--enable-included-printf=yes ${CORECONF}"
-FILES_${PN}_append_mingw32 = " ${libdir}/charset.alias ${libdir}/gthread-2.0.def"
+FILES_${PN}_append_mingw32 = " ${libdir}/charset.alias"
# glib always provides bash-completion output, package the output but prevent
# the dependency chain on bash (via bash-completion) for mingw32 targets only.
@@ -8,3 +8,10 @@ RDEPENDS_${PN}-bash-completion_remove_mingw32 = "bash-completion"
# libmount is not buildable for mingw/windows
PACKAGECONFIG_remove_mingw32 = "libmount"
+FILES_${PN}_append_mingw32 = " \
+ ${bindir}/lib*.dll \
+ ${libexecdir}/*gio-querymodules.exe \
+ "
+FILES_${PN}-dev_append_mingw32 = " ${libdir}/*.def"
+FILES_${PN}-utils_mingw32 = "${bindir}/*.exe"
+