summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit6bd8366b04811e8bd8ff5a2325a7269d64d46add (patch)
tree31ce765341af78223295b97e0162cc46e2e05cdc
parentb4ef177e6ebdc0aded3e202e0decbf1cb21c73dd (diff)
mingw-w64-headers: Add 'secure-api' PACKAGECONFIG
Add the 'secure-api' PACKAGECONFIG and enable it by default. The 'secure-api' feature enables the secure string functions that are provided in the MS C Runtime e.g. "strerror_s". These functions are needed for glib-2.0 compilation. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb
index 06312d6..5cd4e34 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb
@@ -18,6 +18,10 @@ inherit autotools nativesdk
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS = ""
+PACKAGECONFIG ??= "secure-api"
+
+PACKAGECONFIG[secure-api] = "--enable-secure-api,--disable-secure-api"
+
do_configure() {
oe_runconf
}