summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commit8c0f934c9858dd378b759d36e4e9af75fe763351 (patch)
treef03b42428b38a18b4c4975f40ab225bb448347a1
parent7214dd703c982ec521cc9046557731c43f914694 (diff)
libsdl: Fix ${PN}-bin handling for .exe files
For mingw it is convention to have DLLs in bindir. To avoid grouping anything other that .exe files into the ${PN}-bin package, override it so that only '*.exe' files are shipped. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-graphics/libsdl/libsdl_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-graphics/libsdl/libsdl_%.bbappend b/recipes-graphics/libsdl/libsdl_%.bbappend
index 5f5787d..bb65f03 100644
--- a/recipes-graphics/libsdl/libsdl_%.bbappend
+++ b/recipes-graphics/libsdl/libsdl_%.bbappend
@@ -5,3 +5,5 @@ PACKAGECONFIG_class-nativesdk_mingw32 = ""
PACKAGECONFIG[stdio-redirect] = "--enable-stdio-redirect,--disable-stdio-redirect"
PACKAGECONFIG[directx] = "--enable-directx,--disable-directx"
+FILES_${PN}-bin_mingw32 = "${bindir}/*.exe ${sbindir}/*.exe"
+