summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-03-09 23:59:31 +1000
committerJuro Bystricky <juro.bystricky@intel.com>2017-04-06 13:47:39 -0700
commitaa47dd511d3158e00857dc049ded15583884b4bd (patch)
tree792ac6084c7460bb90c40deb51043d5cfd26bc7b
parent60496e2c4226904b612eadf18a3cd5d20290ca93 (diff)
glib-2.0: Prevent a bash dependency via bash-completion
Prevent glib-2.0 depending on bash indirectly due to the RDEPEND on bash-completion. The bash dependency is undesirable due to bash depending on POSIX compatibility (fork, etc) which is not provided by MinGW but instead MSYS or CYGWIN. The glib-2.0 configure does not allow for disabling of bash-completion output, so instead of disabling the bash-completion bbclass entirely allow the output to be packaged but remove the RDEPENDS_${PN}-bash-completion on bash-completion. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-core/glib-2.0/glib-2.0_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-core/glib-2.0/glib-2.0_%.bbappend b/recipes-core/glib-2.0/glib-2.0_%.bbappend
index d0531d6..2b9ec53 100644
--- a/recipes-core/glib-2.0/glib-2.0_%.bbappend
+++ b/recipes-core/glib-2.0/glib-2.0_%.bbappend
@@ -1,2 +1,6 @@
EXTRA_OECONF_mingw32 = "--enable-included-printf=yes ${CORECONF}"
FILES_${PN}_append_mingw32 = " ${libdir}/charset.alias ${libdir}/gthread-2.0.def"
+
+# glib always provides bash-completion output, package the output but prevent
+# the dependency chain on bash (via bash-completion) for mingw32 targets only.
+RDEPENDS_${PN}-bash-completion_remove_mingw32 = "bash-completion"