summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-06-04 21:18:28 +0100
committerRoss Burton <ross.burton@intel.com>2018-06-05 17:40:18 +0100
commitdd69d45d32db2a7bed82f491bace1a4300327638 (patch)
tree14d042016ca5915379a91af6f386e89355d802b9
parent728bfab77d0d3e39b298f3d5d2b53b9c0bc9b536 (diff)
libsdl2: add bbappend to fix build with mingw
We need to disable X11 as we do with libsdl1, and also convince libtool to stop trying to be clever so the build doesn't break. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-graphics/libsdl2/libsdl2_%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-graphics/libsdl2/libsdl2_%.bbappend b/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644
index 0000000..5d8ac54
--- /dev/null
+++ b/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -0,0 +1,13 @@
+# Need to disable X11 explictly as nativesdk-libxdmcp fails:
+# .libs/Fill.o:Fill.c:(.text+0x48): undefined reference to `_imp__recvfrom@24'
+# .libs/Flush.o:Flush.c:(.text+0x36): undefined reference to `_imp__sendto@24'
+PACKAGECONFIG_remove_mingw32_class-nativesdk = "x11"
+
+# libtool doesn't think it can link windres output (COFF) with libtool objects
+# (COFF) , but it can. This might be because file misidentifies version.o:
+#
+# version.o: Targa image data - Map (0) 1 x 65536 x 0 +862 "\004\001.rsrc"
+#
+# Telling libtool to be dumb and just pass the input to the underlying tools
+# works fine.
+EXTRA_OECONF_append_mingw32 = " lt_cv_deplibs_check_method=pass_all"