summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-02 22:42:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-04 11:17:52 +0000
commit67493a015472fcdb53ca6f852c809a5d2390a1ea (patch)
tree12e27de659acff9c966623a1d43cf7c71c621d34 /conf
Initial population
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf9
-rw-r--r--conf/machine-sdk/i686-mingw32.conf2
-rw-r--r--conf/machine-sdk/x86_64-mingw32.conf24
3 files changed, 35 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..a32fa82
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH := "${BBPATH}:${LAYERDIR}"
+
+# We have a packages directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-mingw"
+BBFILE_PATTERN_meta-mingw := "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-mingw = "8"
diff --git a/conf/machine-sdk/i686-mingw32.conf b/conf/machine-sdk/i686-mingw32.conf
new file mode 100644
index 0000000..d9d0952
--- /dev/null
+++ b/conf/machine-sdk/i686-mingw32.conf
@@ -0,0 +1,2 @@
+SDK_ARCH = "i686"
+SDK_OS = "mingw32"
diff --git a/conf/machine-sdk/x86_64-mingw32.conf b/conf/machine-sdk/x86_64-mingw32.conf
new file mode 100644
index 0000000..b41b4a8
--- /dev/null
+++ b/conf/machine-sdk/x86_64-mingw32.conf
@@ -0,0 +1,24 @@
+SDK_ARCH = "x86_64"
+SDK_OS = "mingw32"
+
+GCCTHREADS_mingw32 = "win32"
+
+PREFERRED_PROVIDER_virtual/nativesdk-${SDK_PREFIX}libc-for-gcc = "nativesdk-mingw-w64-runtime"
+PREFERRED_PROVIDER_virtual/nativesdk-libc = "nativesdk-mingw-w64-runtime"
+PREFERRED_PROVIDER_virtual/nativesdk-libintl = "nativesdk-mingw-w64-runtime"
+PREFERRED_PROVIDER_virtual/nativesdk-libiconv = "nativesdk-libiconv"
+
+USE_NLS_mingw32 = "no"
+
+FILES_${PN}-staticdev_append_mingw32 = " ${libdir}/*.lib"
+ALLOW_EMPTY_${PN}_mingw32 = "1"
+
+# Do what amounts to a NOOP
+SDK_PACKAGING_FUNC = "do_compile"
+SDKTAROPTS_append = " -h --hard-dereference"
+
+SDKUSE_NLS = "no"
+
+SDKPKGSUFFIX = "nativesdk-mingw32"
+
+MACHINEOVERRIDES .= ":sdkmingw32"