summaryrefslogtreecommitdiffstats
path: root/recipes-core/glib-2.0/glib-2.0_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/glib-2.0/glib-2.0_%.bbappend')
-rw-r--r--recipes-core/glib-2.0/glib-2.0_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-core/glib-2.0/glib-2.0_%.bbappend b/recipes-core/glib-2.0/glib-2.0_%.bbappend
index 5683364..2accd7a 100644
--- a/recipes-core/glib-2.0/glib-2.0_%.bbappend
+++ b/recipes-core/glib-2.0/glib-2.0_%.bbappend
@@ -1,5 +1,5 @@
EXTRA_OECONF_mingw32 = "--enable-included-printf=yes ${CORECONF}"
-FILES_${PN}_append_mingw32 = " ${libdir}/charset.alias ${libdir}/gthread-2.0.def"
+FILES_${PN}_append_mingw32 = " ${libdir}/charset.alias"
# glib always provides bash-completion output, package the output but prevent
# the dependency chain on bash (via bash-completion) for mingw32 targets only.
@@ -8,3 +8,10 @@ RDEPENDS_${PN}-bash-completion_remove_mingw32 = "bash-completion"
# libmount is not buildable for mingw/windows
PACKAGECONFIG_remove_mingw32 = "libmount"
+FILES_${PN}_append_mingw32 = " \
+ ${bindir}/lib*.dll \
+ ${libexecdir}/*gio-querymodules.exe \
+ "
+FILES_${PN}-dev_append_mingw32 = " ${libdir}/*.def"
+FILES_${PN}-utils_mingw32 = "${bindir}/*.exe"
+