aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-25 12:26:22 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 23:34:28 +0000
commit333437ca8deffa2e2f9d02ae7165c03b4eacdb0d (patch)
tree999b87b810f83c4c9164fed1a7bf8958ac4fcd88
parent3ad2acb0e7d037de7cf9c137e97398a2eb9c42c5 (diff)
qt5-creator: Fix build due to missing lrelease
Fixes make[2]: /mnt/a/yoe/build/tmp/work/i586-yoe-linux-musl/qt5-creator/4.5.1-r0/recipe-sysroot/usr/bin/lrelease: Command not found make[2]: *** [Makefile:420: qtcreator_cs.qm] Error 127 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/linguisttool.patch23
-rw-r--r--recipes-qt/qt5/qt5-creator_4.5.1.bb5
2 files changed, 26 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qt5-creator/linguisttool.patch b/recipes-qt/qt5/qt5-creator/linguisttool.patch
new file mode 100644
index 00000000..6f92d6ab
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/linguisttool.patch
@@ -0,0 +1,23 @@
+Remove path prefix so it can find these tools from buildhost or native packages
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Index: qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro
+===================================================================
+--- qt-creator-opensource-src-4.5.1.orig/share/qtcreator/translations/translations.pro
++++ qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro
+@@ -12,10 +12,10 @@ defineReplace(prependAll) {
+ return($$result)
+ }
+
+-XMLPATTERNS = $$shell_path($$[QT_INSTALL_BINS]/xmlpatterns)
+-LUPDATE = $$shell_path($$[QT_INSTALL_BINS]/lupdate) -locations relative -no-ui-lines -no-sort
+-LRELEASE = $$shell_path($$[QT_INSTALL_BINS]/lrelease)
+-LCONVERT = $$shell_path($$[QT_INSTALL_BINS]/lconvert)
++XMLPATTERNS = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/xmlpatterns
++LUPDATE = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lupdate -locations relative -no-ui-lines -no-sort
++LRELEASE = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lrelease
++LCONVERT = $$OE_QMAKE_PATH_EXTERNAL_HOST_BINS/lconvert
+
+ wd = $$replace(IDE_SOURCE_TREE, /, $$QMAKE_DIR_SEP)
+
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_4.5.1.bb
index 19980285..91db48cb 100644
--- a/recipes-qt/qt5/qt5-creator_4.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_4.5.1.bb
@@ -23,6 +23,7 @@ SRC_URI = " \
http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \
file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \
file://botan-non-x86.patch \
+ file://linguisttool.patch \
file://qtcreator.desktop.in \
"
SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch"
@@ -51,8 +52,8 @@ do_install() {
chrpath --delete ${D}${libexecdir}/qtcreator/qtcreator_process_stub
chrpath --delete ${D}${libexecdir}/qtcreator/qbs_processlauncher
chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/libqbscore.so.*
- chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so
- chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so
+ test -e ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so && chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libcomponentsplugin.so
+ test -e ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so && chrpath --delete ${D}${libdir}/${QT_DIR_NAME}/qtcreator/plugins/qmldesigner/libqtquickplugin.so
}
FILES_${PN} += " \