aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-23 04:09:29 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-19 09:55:34 +0000
commit3e4141cfbb8e2940bf9882a00a3f89e092419198 (patch)
tree5bfb196a3643104f6d4adab8c7a9d5008b97969c
parentc977d68f3a27500f7f9227b4558dadd216384b5c (diff)
qtwebkit: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch69
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb5
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch
new file mode 100644
index 00000000..5cd604e5
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch
@@ -0,0 +1,69 @@
+From 356ef55b985d8d874f2358b937d396bea52ebff6 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 23 Aug 2018 04:06:17 +0000
+Subject: [PATCH] Fix build with non-glibc libc on musl
+
+Need to ensure glibc features are not assumed to be linux-wide
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++----
+ .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++
+ 2 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+index 883914f..ce4e8d3 100644
+--- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
++++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+@@ -566,7 +566,7 @@ void* MachineThreads::Thread::Registers::stackPointer() const
+ #error Unknown Architecture
+ #endif
+
+-#elif defined(__GLIBC__) && ENABLE(JIT)
++#elif defined(__linux__) && ENABLE(JIT)
+
+ #if CPU(X86)
+ return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESP]);
+@@ -665,7 +665,7 @@ void* MachineThreads::Thread::Registers::framePointer() const
+ #error Unknown Architecture
+ #endif
+
+-#elif defined(__GLIBC__)
++#elif defined(__linux__)
+
+ // The following sequence depends on glibc's sys/ucontext.h.
+ #if CPU(X86)
+@@ -747,7 +747,7 @@ void* MachineThreads::Thread::Registers::instructionPointer() const
+ #error Unknown Architecture
+ #endif
+
+-#elif defined(__GLIBC__)
++#elif defined(__linux__)
+
+ // The following sequence depends on glibc's sys/ucontext.h.
+ #if CPU(X86)
+@@ -838,7 +838,7 @@ void* MachineThreads::Thread::Registers::llintPC() const
+ #error Unknown Architecture
+ #endif
+
+-#elif defined(__GLIBC__)
++#elif defined(__linux__)
+
+ // The following sequence depends on glibc's sys/ucontext.h.
+ #if CPU(X86)
+diff --git a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
+index fd7f869..e95391b 100644
+--- a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
++++ b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
+@@ -51,8 +51,10 @@
+ #include <cxxabi.h>
+ #if OS(DARWIN) || (OS(LINUX) && !PLATFORM(GTK))
+ #include <dlfcn.h>
++#if defined(__GLIBC__)
+ #include <execinfo.h>
+ #endif
++#endif
+
+ #if ENABLE(REMOTE_INSPECTOR)
+ #include "JSGlobalObjectDebuggable.h"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index a7dad987..ca2d2156 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -1,7 +1,10 @@
require qt5.inc
require qt5-git.inc
-SRC_URI += "file://0001-Do-not-skip-build-for-cross-compile.patch"
+SRC_URI += "\
+ file://0001-Do-not-skip-build-for-cross-compile.patch \
+ file://0001-Fix-build-with-non-glibc-libc-on-musl.patch \
+"
LICENSE = "BSD & LGPLv2+ | GPL-2.0"
LIC_FILES_CHKSUM = " \