aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-07-02 09:53:22 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-07-02 10:51:41 +0000
commit54ff6c13316cc975852c9712d7086de5ff32da6a (patch)
treef07b259485ff8e37ac858a6b7dc16e595d1711c2
parent5a1ae484fa523568dd9c47f08c25ef336c2626fb (diff)
qtbase: add PACKAGECONFIG for Link Time Optimization
qtbase configure option -ltcg enables Link Time Code Generation using GCC's LTO feature. Enable it by default if the selected optimization is for size. Task-number: QTBUG-68688 Change-Id: I6ca4997e0d91fb2b967a260694d1ac84c983f256 Reviewed-by: Kari Oikarinen <kari.oikarinen@qt.io>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index da0b1d4e..001838bc 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -69,7 +69,7 @@ PACKAGECONFIG_RELEASE ?= "release"
# This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency
# PACKAGECONFIG_OPENSSL ?= "openssl"
PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \
- ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size', '', d)} \
+ ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \
"
PACKAGECONFIG ?= " \
@@ -88,6 +88,7 @@ PACKAGECONFIG[release] = "-release,-debug"
PACKAGECONFIG[debug] = ""
PACKAGECONFIG[developer] = "-developer-build"
PACKAGECONFIG[optimize-size] = "-optimize-size"
+PACKAGECONFIG[ltcg] = "-ltcg"
PACKAGECONFIG[sm] = "-sm,-no-sm"
PACKAGECONFIG[tests] = "-make tests,-nomake tests"
PACKAGECONFIG[examples] = "-make examples -compile-examples,-nomake examples"