aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-14 12:35:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 09:22:18 +0000
commitb716195f609de6547cfdfadfd4fd25292a6bbf09 (patch)
tree023714d64a2dfd392d0d9052761d657225a407df
parent3224b028e70ab3a910ce4fccdd9f3fac4e37011f (diff)
qmake5_paths: change the default QT_DIR_NAME to be empty
* there aren't many people using qt4 and qt5 in the same image anymore, it's time to stop using this work around and to follow default packaging rules Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/qmake5_paths.bbclass2
-rw-r--r--recipes-connectivity/libqofono/libqofono_git.bb6
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.10.1.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/classes/qmake5_paths.bbclass b/classes/qmake5_paths.bbclass
index f3c7b112..ca7e4fc2 100644
--- a/classes/qmake5_paths.bbclass
+++ b/classes/qmake5_paths.bbclass
@@ -2,7 +2,7 @@
# about conflicts with qt4, then you can add qmake5_paths.bbclass
# to your distro layer and flatten all QT_DIR_NAME directories
-QT_DIR_NAME ?= "/qt5"
+QT_DIR_NAME ?= ""
# This is useful for target recipes to reference native mkspecs
QMAKE_MKSPEC_PATH_NATIVE = "${STAGING_LIBDIR_NATIVE}${QT_DIR_NAME}"
diff --git a/recipes-connectivity/libqofono/libqofono_git.bb b/recipes-connectivity/libqofono/libqofono_git.bb
index 303a0057..6b4ec6cf 100644
--- a/recipes-connectivity/libqofono/libqofono_git.bb
+++ b/recipes-connectivity/libqofono/libqofono_git.bb
@@ -26,10 +26,10 @@ FILES_${PN}-tests = " \
/opt/tests/libqofono-qt5 \
"
FILES_${PN} += " \
- ${libdir}/qt5/qml/MeeGo/QOfono/qmldir \
- ${libdir}/qt5/qml/MeeGo/QOfono/libQOfonoQtDeclarative.so \
+ ${OE_QMAKE_PATH_QML}/MeeGo/QOfono/qmldir \
+ ${OE_QMAKE_PATH_QML}/MeeGo/QOfono/libQOfonoQtDeclarative.so \
"
FILES_${PN}-dev += " \
- ${datadir}/qt5/mkspecs \
+ ${OE_QMAKE_PATH_ARCHDATA}/mkspecs \
${libdir}/libqofono-qt5.prl \
"
diff --git a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
index a9b52d9a..505db59d 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
@@ -48,7 +48,7 @@ do_configure_prepend() {
QT_VERSION=`${OE_QMAKE_QMAKE} -query QT_VERSION`
echo "[Qt $QT_VERSION]" >> pyqt.cfg
echo "pyqt_modules = ${PYQT_MODULES}" >> pyqt.cfg
- echo yes | python configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/qt5/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
+ echo yes | python configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
}
do_compile() {