aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-11-15 12:10:22 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-11-15 15:44:01 +0200
commitff6127ddd318d422f595295d1c189a86b3032873 (patch)
treef3c25ef68a18af1658229c5e5dc2687456809fe0
parent6b354b933c526015c1c98e2334cdb29cb5e489e1 (diff)
parentfd1f0f47312e7ee80e5ca65b8b2992cb068b1656 (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.11
* qtyocto/upstream/master: fd1f0f4 python-pyqt5: Update to 5.11.3 and add python3 recipe. 3fa1993 qtbase-native: disable postgresql support 0edbe1b qtbase: refresh patches and update tags on meta-qt5 4ed4385 qtbase: don't leak absolut path to recipe specific sysroot b3502fb qt5: Disable ltcg for host_build 5832bf2 qtbase: don't use thumb for armv[45] Task-number: QTBUG-71658 Change-Id: Ied518deb11fb41e9f91c58419a6efee37a4086d4
-rw-r--r--recipes-python/pyqt5/python-pyqt5.inc (renamed from recipes-python/pyqt5/python-pyqt5_5.10.1.bb)29
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.11.3.bb8
-rw-r--r--recipes-python/pyqt5/python3-pyqt5_5.11.3.bb7
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb8
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb11
-rw-r--r--recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch26
-rw-r--r--recipes-qt/qt5/qtbase/0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch66
-rw-r--r--recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb9
10 files changed, 141 insertions, 27 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb b/recipes-python/pyqt5/python-pyqt5.inc
index 505db59d..c5ff46cf 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
+++ b/recipes-python/pyqt5/python-pyqt5.inc
@@ -6,20 +6,16 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "\
file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
"
-DEPENDS = "sip sip-native qtbase python"
-
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyqt/PyQt5_gpl-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "be36c2abaffc9daa8b993f1ca982968f"
-SRC_URI[sha256sum] = "9932e971e825ece4ea08f84ad95017837fa8f3f29c6b0496985fa1093661e9ef"
+SRC_URI[md5sum] = "aac3428e90eca5df68c5764282fd9b98"
+SRC_URI[sha256sum] = "c9b57d15601d436faf35dacf8e0acefa220194829a653e771e80b189b3261073"
S = "${WORKDIR}/PyQt5_gpl-${PV}"
-
-inherit qmake5 pythonnative python-dir distro_features_check
-# depends on qt4-x11-free
-REQUIRED_DISTRO_FEATURES = "x11"
+inherit qmake5
+DEPENDS = "qtbase"
export BUILD_SYS
export HOST_SYS
@@ -36,19 +32,19 @@ PYQT_MODULES_aarch64 = "QtCore QtGui QtNetwork QtWidgets"
do_configure_prepend() {
cd ${S}
echo "py_platform = linux" > pyqt.cfg
- echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)" >> pyqt.cfg
- echo "py_pylib_dir = %(sysroot)/${libdir}/python%(py_major).%(py_minor)" >> pyqt.cfg
- echo "py_pylib_lib = python%(py_major).%(py_minor)mu" >> pyqt.cfg
- echo "pyqt_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> pyqt.cfg
+ echo "py_inc_dir = %(sysroot)/$includedir/python${PYTHON_BASEVERSION}${PYTHON_ABI}" >> pyqt.cfg
+ echo "py_pylib_dir = %(sysroot)/${libdir}/python${PYTHON_BASEVERSION}${PYTHON_ABI}" >> pyqt.cfg
+ echo "py_pylib_lib = python${PYTHON_BASEVERSION}${PYTHON_ABI}" >> pyqt.cfg
+ echo "pyqt_module_dir = ${D}/${libdir}/python${PYTHON_BASEVERSION}${PYTHON_ABI}/site-packages" >> pyqt.cfg
echo "pyqt_bin_dir = ${D}/${bindir}" >> pyqt.cfg
echo "pyqt_sip_dir = ${D}/${datadir}/sip/PyQt5" >> pyqt.cfg
- echo "pyuic_interpreter = ${D}/${bindir}/python%(py_major).%(py_minor)" >> pyqt.cfg
+ echo "pyuic_interpreter = ${D}/${bindir}/python${PYTHON_BASEVERSION}${PYTHON_ABI}" >> pyqt.cfg
echo "pyqt_disabled_features = ${DISABLED_FEATURES}" >> pyqt.cfg
echo "qt_shared = True" >> pyqt.cfg
QT_VERSION=`${OE_QMAKE_QMAKE} -query QT_VERSION`
echo "[Qt $QT_VERSION]" >> pyqt.cfg
echo "pyqt_modules = ${PYQT_MODULES}" >> pyqt.cfg
- echo yes | python configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
+ echo yes | ${PYTHON} configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
}
do_compile() {
@@ -61,7 +57,6 @@ do_install() {
oe_runmake install
}
-RDEPENDS_${PN} = "python-core python-sip qtbase"
-
-FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt5/"
+FILES_${PN} += "${libdir}/${PYTHON_DIR}${PYTHON_ABI}/site-packages ${datadir}/sip/PyQt5/"
+RDEPENDS_${PN} = "qtbase"
diff --git a/recipes-python/pyqt5/python-pyqt5_5.11.3.bb b/recipes-python/pyqt5/python-pyqt5_5.11.3.bb
new file mode 100644
index 00000000..6b1b5701
--- /dev/null
+++ b/recipes-python/pyqt5/python-pyqt5_5.11.3.bb
@@ -0,0 +1,8 @@
+require python-pyqt5.inc
+
+inherit pythonnative python-dir
+
+DEPENDS += "sip sip-native python"
+
+RDEPENDS_${PN} += "python-core python-sip"
+
diff --git a/recipes-python/pyqt5/python3-pyqt5_5.11.3.bb b/recipes-python/pyqt5/python3-pyqt5_5.11.3.bb
new file mode 100644
index 00000000..200a8154
--- /dev/null
+++ b/recipes-python/pyqt5/python3-pyqt5_5.11.3.bb
@@ -0,0 +1,7 @@
+require python-pyqt5.inc
+
+inherit python3native python3-dir
+
+DEPENDS += "sip3 sip3-native python3"
+
+RDEPENDS_${PN} += "python3-core python3-sip3"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 51164286..5c7afea8 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.11
+# 5.11.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -40,13 +40,15 @@ SRC_URI += "\
file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
+ file://0016-Disable-ltcg-for-host_build.patch \
+ file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-native
-# 5.11.meta-qt5-native.11
+# 5.11.meta-qt5-native.12
SRC_URI += " \
- file://0016-Always-build-uic-and-qvkgen.patch \
+ file://0018-Always-build-uic-and-qvkgen.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 973af628..9b37864a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.11
+# 5.11.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -35,18 +35,20 @@ SRC_URI += "\
file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
+ file://0016-Disable-ltcg-for-host_build.patch \
+ file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-native
-# 5.11.meta-qt5-native.11
+# 5.11.meta-qt5-native.12
SRC_URI += " \
- file://0016-Always-build-uic-and-qvkgen.patch \
+ file://0018-Always-build-uic-and-qvkgen.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0017-Bootstrap-without-linkat-feature.patch \
+ file://0019-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
@@ -67,6 +69,7 @@ PACKAGECONFIG_CONFARGS = " \
-no-gui \
-no-sql-mysql \
-no-sql-sqlite \
+ -no-sql-psql \
-no-opengl \
-no-openssl \
-no-xcb \
diff --git a/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch
new file mode 100644
index 00000000..6d4e6968
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch
@@ -0,0 +1,26 @@
+From 3b9861c92444d50198ca74e60bcf10738998b7e9 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Tue, 23 Oct 2018 09:54:57 +0300
+Subject: [PATCH] Disable ltcg for host_build
+
+debug-prefix-map does not work correctly for static libraries
+when using ltcg, and since host_build compilations link agaist
+the libQt5Bootstrap.a library, it breaks source file packaging
+into debug packages.
+
+Task-number: QTBUG-71230
+Upstream-Status: Inappropriate [embedded specific]
+---
+ mkspecs/features/ltcg.prf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
+index ccf0226272..482e5b573d 100644
+--- a/mkspecs/features/ltcg.prf
++++ b/mkspecs/features/ltcg.prf
+@@ -1,4 +1,4 @@
+-CONFIG(release, debug|release) {
++CONFIG(release, debug|release):!host_build {
+ # We need fat object files when creating static libraries on some platforms
+ # so the linker will know to load a particular object from the library
+ # in the first place. On others, we have special ar and nm to create the symbol
diff --git a/recipes-qt/qt5/qtbase/0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
new file mode 100644
index 00000000..3460568c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -0,0 +1,66 @@
+From a154d5f20d85108fcbf36f9f39cb853438f98127 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Sat, 27 Oct 2018 12:29:31 +0000
+Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
+ sysroot
+
+EGL is configured to need an include path into the recipe-specific sysroot.
+However users of the cmake file will have a different absolute path than that
+used when creating the cmake file from cmake.in in qtbase.
+
+Change to store the relative path within the sysroot and then prepend the
+currently used sysroot in the _qt5gui_find_extra_libs macro.
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ src/gui/Qt5GuiConfigExtras.cmake.in | 22 ++++++++--------------
+ 1 file changed, 8 insertions(+), 14 deletions(-)
+
+diff --git a/src/gui/Qt5GuiConfigExtras.cmake.in b/src/gui/Qt5GuiConfigExtras.cmake.in
+index 07869efd7d..671aa82167 100644
+--- a/src/gui/Qt5GuiConfigExtras.cmake.in
++++ b/src/gui/Qt5GuiConfigExtras.cmake.in
+@@ -75,21 +75,15 @@ unset(_qt5gui_OPENGL_INCLUDE_DIR CACHE)
+
+ macro(_qt5gui_find_extra_libs Name Libs LibDir IncDirs)
+ set(Qt5Gui_${Name}_LIBRARIES)
+-!!IF !mac
+- set(Qt5Gui_${Name}_INCLUDE_DIRS ${IncDirs})
+-!!ELSE
++
+ foreach(_dir ${IncDirs})
+- if (EXISTS ${_dir})
+- list(APPEND Qt5Gui_${Name}_INCLUDE_DIRS ${_dir})
+- else()
+- find_path(_actual_dir ${_dir}) # Look in sdk directories
+- if (_actual_dir)
+- list(APPEND Qt5Gui_${Name}_INCLUDE_DIRS ${_actual_dir})
+- endif()
+- unset(_actual_dir CACHE)
++ find_path(_actual_dir ${_dir})
++ if (_actual_dir)
++ list(APPEND Qt5Gui_${Name}_INCLUDE_DIRS ${_actual_dir})
+ endif()
++ unset(_actual_dir CACHE)
+ endforeach()
+-!!ENDIF
++
+ foreach(_lib ${Libs})
+ string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
+ if (NOT TARGET Qt5::Gui_${_cmake_lib_name} AND NOT _Qt5Gui_${_cmake_lib_name}_LIBRARY_DONE)
+@@ -158,11 +152,11 @@ endmacro()
+
+
+ !!IF !isEmpty(CMAKE_EGL_LIBS)
+-_qt5gui_find_extra_libs(EGL \"$$CMAKE_EGL_LIBS\" \"$$CMAKE_EGL_LIBDIR\" \"$$CMAKE_EGL_INCDIRS\")
++_qt5gui_find_extra_libs(EGL \"$$CMAKE_EGL_LIBS\" \"$$CMAKE_EGL_LIBDIR\" \"$$replace(CMAKE_EGL_INCDIRS,$$re_escape($$PKG_CONFIG_SYSROOT_DIR),)\")
+ !!ENDIF
+
+ !!IF !isEmpty(CMAKE_OPENGL_LIBS)
+-_qt5gui_find_extra_libs(OPENGL \"$$CMAKE_OPENGL_LIBS\" \"$$CMAKE_OPENGL_LIBDIR\" \"$$CMAKE_OPENGL_INCDIRS\")
++_qt5gui_find_extra_libs(OPENGL \"$$CMAKE_OPENGL_LIBS\" \"$$CMAKE_OPENGL_LIBDIR\" \"$$replace(CMAKE_OPENGL_INCDIRS,$$re_escape($$PKG_CONFIG_SYSROOT_DIR),)\")
+
+ !!ENDIF
+
diff --git a/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
index 732e2fb7..d2d00be0 100644
--- a/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 7b5433027e9c75902b83a2990e09ae221d98451e Mon Sep 17 00:00:00 2001
+From 531068a88afa3336455134d85c16934bb4002124 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch
index 66dc8404..16923cd4 100644
--- a/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 739dd4920bc16919c81c62bcddadc6958599792c Mon Sep 17 00:00:00 2001
+From 0d6a38d7bec0a3017a9e325f5e2b6e6168359b33 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 60ed2971..76f776f5 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.11
+# 5.11.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -31,6 +31,8 @@ SRC_URI += "\
file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
+ file://0016-Disable-ltcg-for-host_build.patch \
+ file://0017-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
"
@@ -173,6 +175,11 @@ deltask generate_qt_config_file
XPLATFORM_toolchain-clang = "linux-oe-clang"
XPLATFORM ?= "linux-oe-g++"
+# Causes qdrawhelper.s: Error: unaligned opcodes detected in executable segment
+# when building qtbase/5.6.3+gitAUTOINC+e6f8b072d2-r0/git/src/gui/painting/qdrawhelper.cpp
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
do_configure() {
# Regenerate header files when they are included in source tarball
# Otherwise cmake files don't set PRIVATE_HEADERS correctly