aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-06-06 13:08:30 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-08-11 06:32:55 +0000
commitb72dbdfcb6e1e3c520de216cda4d0893d6372bd2 (patch)
tree113f00de9d6539a132b5b63683e0c6771329d7ee
parentdc32862fb82686c30722970619ad1187695e6e60 (diff)
qt5: update submodules
Update submodules to Qt 5.6.3 (snapshot 1) Change-Id: I67d3799d7822173a6cbe9b3e60223dca79ae7f6e Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch10
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb3
-rw-r--r--recipes-qt/qt5/qtwayland/0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch156
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb3
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb12
-rw-r--r--recipes-qt/qt5/qtwebkit-examples_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
32 files changed, 39 insertions, 199 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 54a5b521..47f7fff1 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -239,4 +239,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "b4ada3f0d8feed7dbff22aa780d38ab126020ac6"
+SRCREV = "1131db8b4708dfa222b50fb4981a7becaf5ae4a3"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 7b289dad..da87c1c1 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -27,6 +27,6 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/*/*/*.obj \
"
-SRCREV = "d3889211dc245d44dab25dcc9fbbc4b57e92ac33"
+SRCREV = "fc781fa42287a4f5db62a346ad6eb8bcbb9f49c0"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 2bc7b9b0..91298dd7 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -11,4 +11,4 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-PV = "5.6.2+git${SRCPV}"
+PV = "5.6.3+git${SRCPV}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index a928a9a4..608b41a0 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -117,4 +117,4 @@ do_install() {
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
}
-SRCREV = "b4ada3f0d8feed7dbff22aa780d38ab126020ac6"
+SRCREV = "1131db8b4708dfa222b50fb4981a7becaf5ae4a3"
diff --git a/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch b/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
index 70a71ff9..621e3412 100644
--- a/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
+++ b/recipes-qt/qt5/qtbase/0002-configure-Separate-host-and-build-platform.patch
@@ -1,4 +1,4 @@
-From d98f945aade15bf49eb7c016d2eefd513351b360 Mon Sep 17 00:00:00 2001
+From cb1e143a42e41524f16043c92b728dfae54586f9 Mon Sep 17 00:00:00 2001
From: David Schulz <david.schulz@theqtcompany.com>
Date: Mon, 12 Oct 2015 09:55:30 +0200
Subject: [PATCH] configure: Separate host and build platform.
@@ -76,7 +76,7 @@ index bc5258c..f5db184 100755
-spec "$QMKSPEC" \
"CONFIG+=$QMAKE_CONFIG" \
diff --git a/configure b/configure
-index 55b1886..ef9c29b 100755
+index 2073880..79eabe0 100755
--- a/configure
+++ b/configure
@@ -105,9 +105,11 @@ QT_CONFIG=
@@ -594,15 +594,15 @@ index 3123f7c..0000000
-TEMPLATE = aux
-QMAKE_DOCS = $$PWD/doc/qmake.qdocconf
diff --git a/qtbase.pro b/qtbase.pro
-index 98ca86a..11cff9e 100644
+index 78f9b3a..88ff2de 100644
--- a/qtbase.pro
+++ b/qtbase.pro
@@ -4,7 +4,7 @@
load(qt_parts)
--SUBDIRS += qmake/qmake-docs.pro
-+SUBDIRS += qmake/qmake-aux.pro
+-SUBDIRS += qmake/qmake-docs.pro doc
++SUBDIRS += qmake/qmake-aux.pro doc
cross_compile: CONFIG += nostrip
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 114acdf3..cd94344a 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -253,4 +253,4 @@ sysroot_stage_dirs_append() {
rm -rf $to${OE_QMAKE_PATH_QT_FONTS}
}
-SRCREV = "b4ada3f0d8feed7dbff22aa780d38ab126020ac6"
+SRCREV = "1131db8b4708dfa222b50fb4981a7becaf5ae4a3"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 8025178c..db2f06ac 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "85fe2daab5ed14655b456df8821c9f5f606fdc12"
+SRCREV = "61804e56b82330fac0f29beec0e56262233467bb"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3252411e..d117c859 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -25,4 +25,4 @@ do_configure_prepend() {
sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro
}
-SRCREV = "bd7649557e99be543b78492d96bb2982e0a3e4c4"
+SRCREV = "825c0c8d54a7009c6af5cb73736138150cc5cc63"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 82468158..5e0e6620 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -39,6 +39,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "c1d726fe19c83cf081042e55ace9d9d7b31c40e6"
+SRCREV = "caa273e3bc6a2bece76c190b4135103eb7bbeab9"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 24ae3e1b..89fd4297 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "0b68e91d68902c4d05d0bb8aa045ae76c4e8c9b5"
+SRCREV = "4dc734d85f59e3a16a50a9d7ffebc7aa304f5243"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index e7bce9de..974cbd07 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -28,4 +28,4 @@ EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'jasper', 'CONFIG+
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'libtiff', 'CONFIG+=OE_LIBTIFF_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'libwebp', 'CONFIG+=OE_LIBWEBP_ENABLED', '', d)}"
-SRCREV = "d7bdc138b89bf0c52ba9ddf22b34d2ccd06b3936"
+SRCREV = "b6ffd71e2315e699d4ad32859cf36c67635820e7"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 80d7699a..09ab0cae 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -29,4 +29,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'geoclue', 'CONFIG+=OE_GEOCLUE_ENABLED', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'gypsy', 'CONFIG+=OE_GYPSY_ENABLED', '', d)}"
-SRCREV = "7d01112c36a98912706e9d33ce2e36126de0ccec"
+SRCREV = "d2b7d77b7d882e00a2c1bb938a04493e4b1b6d44"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 8e3da52d..6ba03e31 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
file://0001-Initial-porting-effort-to-GStreamer-1.0.patch \
"
-SRCREV = "20686cb51fb2dfa5973d636875e9fc20c2bde4f5"
+SRCREV = "6d4948122063b651948a5c4db2197d633d7e96c4"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index 6c2d3095..0c5d2cb6 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -26,4 +26,4 @@ do_configure_prepend() {
sed -i 's#^qtHaveModule(webkitwidgets):#qtHaveModule(webkitwidgets):!contains(CONFIG, noqtwebkit):#g' ${S}/src/imports/imports.pro
}
-SRCREV = "5eab543c5c955f5057225b9bdb6b2757516dbd3e"
+SRCREV = "b934c54583adc4f9021de2753f99836f60a96688"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 32053e45..fc2eaa00 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -12,4 +12,4 @@ DEPENDS += "qtdeclarative"
FILES_${PN}-qmlplugins += "${libdir}/qt5/qml/Qt"
-SRCREV = "e93c73c0aa15cd973e008a04a70a7c69719ad244"
+SRCREV = "be77d8798a1df1cb928b944c145db3fa9aeb9777"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index aeaa9678..0062489f 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "59c6c0e0b1b5b46747595a58e11311b7393d7e70"
+SRCREV = "a1149499650fe989016160941a715020aad42893"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 21199f76..6e2327aa 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -27,4 +27,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "9dc78a2d847bca5ec7b1445356523383a030d7ce"
+SRCREV = "8196140bedcaca11dbe0e06342e942e52e9d69eb"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 345c5cb9..fa77a636 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -14,4 +14,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "922c2bb671c113b7e481fb86f823188b4bce1d3e"
+SRCREV = "12b98b6ff70a18c27f543dda029e75c197d8cbc5"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index fdcba1e3..8764622c 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "46ef9fdc130a06bd80c5c004f0dc95c473f704c8"
+SRCREV = "9e4b9d276f0de2d298da4ffdf6f15a9960402194"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 145ac65f..a17b885c 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "2d55b4996eaa26c973afdf15f6f703c0a1840a96"
+SRCREV = "810b6defac666c7652a77b5e4fd5b70a6fbe0c54"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 0e7b6697..59a380e0 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -31,6 +31,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
-SRCREV = "a9e5e09f156b09c7f65e0b57fe191d71f9c1aa3e"
+SRCREV = "a4f656126803b6cfac8ac4b442ee975562145b73"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 5995c991..6e40b9e2 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -114,4 +114,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "225e1740fec4559bf8d66d915ddd06b9d4f48119"
+SRCREV = "e0ee24efee5472d353accb70fa86274bc34a34db"
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
index ab2eaed7..a8c38609 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bb
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -15,7 +15,6 @@ DEPENDS = "qtbase-native wayland-native"
SRC_URI += " \
file://0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch \
- file://0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch \
"
do_configure() {
@@ -26,4 +25,4 @@ do_install() {
oe_runmake install INSTALL_ROOT=${D}
}
-SRCREV = "82e11583928d47576c160d35c9df05c0eec34df8"
+SRCREV = "d6f7bb39e71777ce5568d462841caccc17f3a205"
diff --git a/recipes-qt/qt5/qtwayland/0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch b/recipes-qt/qt5/qtwayland/0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch
deleted file mode 100644
index d173e673..00000000
--- a/recipes-qt/qt5/qtwayland/0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-From de85e1c1ee76be845a21b441d9e4ea12a30d84c7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Vesa=20J=C3=A4=C3=A4skel=C3=A4inen?= <dachaac@gmail.com>
-Date: Sun, 18 Sep 2016 11:51:59 +0300
-Subject: [PATCH] Fix building of QWaylandIntegration if some Qt5 features are
- disabled.
-
-QPlatformIntegration's interface methods are disabled based on QT_NO_OPENGL,
-QT_NO_CLIPBOARD, QT_NO_DRAGANDDROP, QT_NO_ACCESSIBILITY and
-QT_NO_SESSIONMANAGER, these has to be taken into account when compiling
-QtWayland.
----
- src/client/qwaylandintegration.cpp | 21 ++++++++++++++++++---
- src/client/qwaylandintegration_p.h | 12 ++++++++++++
- 2 files changed, 30 insertions(+), 3 deletions(-)
-
-diff --git a/src/client/qwaylandintegration.cpp b/src/client/qwaylandintegration.cpp
-index 39fff53..481e3d6 100644
---- a/src/client/qwaylandintegration.cpp
-+++ b/src/client/qwaylandintegration.cpp
-@@ -39,7 +39,9 @@
- #include "qwaylandinputcontext_p.h"
- #include "qwaylandshmbackingstore_p.h"
- #include "qwaylandnativeinterface_p.h"
-+#ifndef QT_NO_CLIPBOARD
- #include "qwaylandclipboard_p.h"
-+#endif
- #include "qwaylanddnd_p.h"
- #include "qwaylandwindowmanagerintegration_p.h"
- #include "qwaylandscreen_p.h"
-@@ -57,7 +59,9 @@
- #include <QSocketNotifier>
-
- #include <qpa/qplatforminputcontextfactory_p.h>
-+#ifndef QT_NO_ACCESSIBILITY
- #include <qpa/qplatformaccessibility.h>
-+#endif
- #include <qpa/qplatforminputcontext.h>
-
- #include "qwaylandhardwareintegration_p.h"
-@@ -117,8 +121,6 @@ QWaylandIntegration::QWaylandIntegration()
- , mNativeInterface(new QWaylandNativeInterface(this))
- #ifndef QT_NO_ACCESSIBILITY
- , mAccessibility(new QPlatformAccessibility())
--#else
-- , mAccessibility(0)
- #endif
- , mClientBufferIntegrationInitialized(false)
- , mServerBufferIntegrationInitialized(false)
-@@ -126,9 +128,12 @@ QWaylandIntegration::QWaylandIntegration()
- {
- initializeInputDeviceIntegration();
- mDisplay = new QWaylandDisplay(this);
-+#ifndef QT_NO_CLIPBOARD
- mClipboard = new QWaylandClipboard(mDisplay);
-+#endif
-+#ifndef QT_NO_DRAGANDDROP
- mDrag = new QWaylandDrag(mDisplay);
--
-+#endif
- QString icStr = QPlatformInputContextFactory::requested();
- icStr.isNull() ? mInputContext.reset(new QWaylandInputContext(mDisplay))
- : mInputContext.reset(QPlatformInputContextFactory::create(icStr));
-@@ -136,8 +141,12 @@ QWaylandIntegration::QWaylandIntegration()
-
- QWaylandIntegration::~QWaylandIntegration()
- {
-+#ifndef QT_NO_DRAGANDDROP
- delete mDrag;
-+#endif
-+#ifndef QT_NO_CLIPBOARD
- delete mClipboard;
-+#endif
- #ifndef QT_NO_ACCESSIBILITY
- delete mAccessibility;
- #endif
-@@ -213,15 +222,19 @@ QPlatformFontDatabase *QWaylandIntegration::fontDatabase() const
- return mFontDb;
- }
-
-+#ifndef QT_NO_CLIPBOARD
- QPlatformClipboard *QWaylandIntegration::clipboard() const
- {
- return mClipboard;
- }
-+#endif
-
-+#ifndef QT_NO_DRAGANDDROP
- QPlatformDrag *QWaylandIntegration::drag() const
- {
- return mDrag;
- }
-+#endif
-
- QPlatformInputContext *QWaylandIntegration::inputContext() const
- {
-@@ -243,10 +256,12 @@ QVariant QWaylandIntegration::styleHint(StyleHint hint) const
- return QPlatformIntegration::styleHint(hint);
- }
-
-+#ifndef QT_NO_ACCESSIBILITY
- QPlatformAccessibility *QWaylandIntegration::accessibility() const
- {
- return mAccessibility;
- }
-+#endif
-
- QPlatformServices *QWaylandIntegration::services() const
- {
-diff --git a/src/client/qwaylandintegration_p.h b/src/client/qwaylandintegration_p.h
-index 987d805..b50ad95 100644
---- a/src/client/qwaylandintegration_p.h
-+++ b/src/client/qwaylandintegration_p.h
-@@ -80,15 +80,21 @@ public:
-
- QPlatformNativeInterface *nativeInterface() const Q_DECL_OVERRIDE;
-
-+#ifndef QT_NO_CLIPBOARD
- QPlatformClipboard *clipboard() const Q_DECL_OVERRIDE;
-+#endif
-
-+#ifndef QT_NO_DRAGANDDROP
- QPlatformDrag *drag() const Q_DECL_OVERRIDE;
-+#endif
-
- QPlatformInputContext *inputContext() const Q_DECL_OVERRIDE;
-
- QVariant styleHint(StyleHint hint) const Q_DECL_OVERRIDE;
-
-+#ifndef QT_NO_ACCESSIBILITY
- QPlatformAccessibility *accessibility() const Q_DECL_OVERRIDE;
-+#endif
-
- QPlatformServices *services() const Q_DECL_OVERRIDE;
-
-@@ -117,12 +123,18 @@ private:
- void initializeInputDeviceIntegration();
-
- QPlatformFontDatabase *mFontDb;
-+#ifndef QT_NO_CLIPBOARD
- QPlatformClipboard *mClipboard;
-+#endif
-+#ifndef QT_NO_DRAGANDDROP
- QPlatformDrag *mDrag;
-+#endif
- QWaylandDisplay *mDisplay;
- QPlatformNativeInterface *mNativeInterface;
- QScopedPointer<QPlatformInputContext> mInputContext;
-+#ifndef QT_NO_ACCESSIBILITY
- QPlatformAccessibility *mAccessibility;
-+#endif
- bool mClientBufferIntegrationInitialized;
- bool mServerBufferIntegrationInitialized;
- bool mShellIntegrationInitialized;
---
-2.7.4
-
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 6c15b69f..0439ab2f 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -34,7 +34,6 @@ FILES_${PN}-plugins-dbg += " \
SRC_URI += " \
file://0001-examples-wayland-include-server-buffer-only-when-bui.patch \
- file://0001-Fix-building-of-QWaylandIntegration-if-some-Qt5-feat.patch \
"
-SRCREV = "82e11583928d47576c160d35c9df05c0eec34df8"
+SRCREV = "d6f7bb39e71777ce5568d462841caccc17f3a205"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 55a1cb92..001e8ca0 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "3b28a6956cb3cab087481312dc82a907b118e0de"
+SRCREV = "18a53cef73eed59cddd7962d4e4aa8fbf7d3170a"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1e903ae2..c368bbdd 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -2,11 +2,9 @@ SUMMARY = "QtWebEngine combines the power of Chromium and Qt"
LICENSE = "LGPL-3.0 & BSD"
LIC_FILES_CHKSUM = " \
- file://src/core/browser_context_qt.cpp;md5=5fe719c44250955a5d5f8fb15fc8b1da;beginline=1;endline=35 \
- file://src/3rdparty/chromium/LICENSE;md5=537e0b52077bf0a616d0a0c8a79bc9d5 \
- file://LICENSE.LGPLv3;md5=8211fde12cc8a4e2477602f5953f5b71 \
+ file://src/core/browser_context_qt.cpp;md5=8b5dcd02451f832169d229afb56f27fd;beginline=1;endline=35 \
+ file://src/3rdparty/chromium/LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d \
file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
- file://LICENSE.GPLv2;md5=c96076271561b0e3785dad260634eaa8 \
"
DEPENDS += " \
@@ -107,7 +105,7 @@ RDEPENDS_${PN}-examples += " \
qtdeclarative-qmlplugins \
"
-QT_MODULE_BRANCH_CHROMIUM = "45-based"
+QT_MODULE_BRANCH_CHROMIUM = "49-based"
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \
@@ -120,10 +118,10 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "ec84507898e58a167b185ba674acf300cc695380"
+SRCREV_qtwebengine = "e4ea5215ff40e5e179aeeeaa320e588a25c3ec13"
# This is in git submodule, but we're using latest in 45-based
# SRCREV_chromium = "79930a541473b2e0f950d040c16ab6f22e4aeef3"
-SRCREV_chromium = "4d61c01b71fcbe706ea4220d33294d4f5600ca31"
+SRCREV_chromium = "a0b159a148a8de89ad44fa2d64e488fd9a4aee87"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb
index 3f1ab500..65a8196e 100644
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ b/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -19,4 +19,4 @@ DEPENDS += "qtwebkit qtxmlpatterns"
RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
-SRCREV = "2a143bf81b2ffb3bd7a5f47cf719e6ed347bf383"
+SRCREV = "0c623fab420102c54fa533da3b8ca774290d6d13"
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 3d2dbdf8..b7848978 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -71,4 +71,4 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db
RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }"
export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}"
-SRCREV = "bb43bca1664721401c3a2c25b585913bb5e8cb4f"
+SRCREV = "95a78c9f04d9a3f954477855f84180ced556a480"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index c71a69f3..6cdf58a3 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "ef7b03e3e5e20f89963bae799f7ecb753f332c34"
+SRCREV = "d3032491971e1cee8f1171f16b8e6d3d2fa42eed"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index eaed56c4..e4839f39 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "df10edcfae328f397c99192b322268c9e96f6dab"
+SRCREV = "25e20a724f411f6e07cd3dc9f4870298a308c2c3"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index f715f1e7..15314b00 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -13,6 +13,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "074571305e45d30066b199641eb5d0866e3b0a92"
+SRCREV = "0533f8ba47f57da5d7363c2c00cf0b239ce72888"
BBCLASSEXTEND =+ "native nativesdk"