aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-09-16 12:52:45 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-10-03 14:38:52 +0300
commitd778a6ca6fa7df4d16f5b0264bea010a91d21ad5 (patch)
treed188d9e1abddfc7ea507f62184a44983945d916a
parente8ee8bc088936129ca0d1335fc09c4e9e2a4aaa6 (diff)
parentdc2dedef9961950b88f4245ba7499538ec4244ab (diff)
Merge remote-tracking branch 'qtyocto/upstream/warrior' into 5.12
* upstream/warrior: dc2dede qtserialbus: Fix build with 5.2+ kernel headers b4f9f22 qtwebengine: Fix compile failure with 5.2+ kernel headers Conflicts: recipes-qt/qt5/qtserialbus_git.bb Change-Id: I9d44d28ba4918b1a570819f6bbefd10511ad7cd2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch31
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
new file mode 100644
index 00000000..1e5d4e26
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
@@ -0,0 +1,31 @@
+From c5ae85ce82fec2333d6b8af3d1f17343fd0eb0ba Mon Sep 17 00:00:00 2001
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Thu, 11 Jul 2019 09:35:13 +0200
+Subject: [PATCH] chromium: fix build after y2038 changes in glibc
+
+SIOCGSTAMP is defined in linux/sockios.h since kernel 5.2. Include that
+file wherever needed.
+
+Signed-off-by: Jiri Slaby <jslaby@suse.cz>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+Upstream-Status: Submitted
+Patch-mainline: submitted on 2019/07/11
+References: QTBUG-76963
+
+---
+ chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc b/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
+index ca78499179a..d91d17f8f00 100644
+--- a/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
++++ b/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
+@@ -68,6 +68,7 @@ typedef void* SockOptArg;
+ #endif // WEBRTC_POSIX
+
+ #if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
++#include <linux/sockios.h>
+
+ int64_t GetSocketRecvTimestamp(int socket) {
+ struct timeval tv_ioctl;
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index c3cea2bc..8f0b23be 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -156,6 +156,7 @@ SRC_URI += " \
file://chromium/0020-chromium-Check-for-__ARM_FP-2-before-using-__fp16.patch;patchdir=src/3rdparty \
file://chromium/0021-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
file://chromium/0022-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
+ file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\