aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-15 10:34:32 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-15 10:35:01 +0300
commit5fdfbec8369f990bd4b9def1294ade6bbf60e143 (patch)
tree890bd6a48788264d34994beaadbc0881c162f21c
parent63dec9bbd826a4afafa7177aaa3439467f25d80a (diff)
parent0d0eca50521fcde987be3b97ffd29442db7435ff (diff)
Merge remote-tracking branch 'origin/5.12' into 5.13
* origin/5.12: qt5: update to Qt 5.12.5 Add CI build instructions qt5-creator: fix build with musl ogl-runtime: fix build on musl libc Change-Id: Ia5d0e73a06489bebf70897805bb0aa314ba5a663
-rw-r--r--.gitattributes1
-rw-r--r--coin/module_config.yaml180
-rw-r--r--recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch26
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb1
4 files changed, 208 insertions, 0 deletions
diff --git a/.gitattributes b/.gitattributes
index cb2381c0..f6a86105 100644
--- a/.gitattributes
+++ b/.gitattributes
@@ -1,2 +1,3 @@
+/coin export-ignore
# linguist overrides
recipes-*/**/*.inc linguist-language=BitBake
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
new file mode 100644
index 00000000..263d8f04
--- /dev/null
+++ b/coin/module_config.yaml
@@ -0,0 +1,180 @@
+version: 1
+accept_configuration:
+ condition: and
+ conditions:
+ - condition: property
+ property: host.osVersion
+ equals_value: Ubuntu_18_04
+ - condition: property
+ property: target.osVersion
+ equals_value: QEMU
+ - condition: property
+ property: target.arch
+ in_values: [ARMv7, ARM64]
+
+environment: &environment
+ type: Group
+ instructions:
+ - type: EnvironmentVariable
+ variableName: POKY_SHA1
+ variableValue: 38d5c8ea98cfa49825c473eba8984c12edf062be
+ - type: EnvironmentVariable
+ variableName: OE_SHA1
+ variableValue: 8d5dcd6522e9d15e68637b6d7dda0401f9bb91d0
+ - type: EnvironmentVariable
+ variableName: MACHINE
+ variableValue: qemuarm64
+ enable_if:
+ condition: property
+ property: target.arch
+ equals_value: ARM64
+ - type: EnvironmentVariable
+ variableName: MACHINE
+ variableValue: qemux86
+ enable_if:
+ condition: property
+ property: target.arch
+ equals_value: ARMv7
+
+build_instructions:
+ - *environment
+ - type: SetBuildDirectory
+ directory: "{{.AgentWorkingDir}}/build"
+ - type: MakeDirectory
+ directory: "{{.BuildDir}}"
+ - type: ChangeDirectory
+ directory: "{{.BuildDir}}"
+ - type: ExecuteCommand
+ command: ["sudo", "mkdir", "-p", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Could not create '/mnt/yocto-cache' directory"
+ - type: ExecuteCommand
+ command: ["sudo", "mount", "yocto-cache.intra.qt.io:/srv/yocto-cache", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Could not mount yocto cache."
+ - type: WriteFile
+ fileContents: |
+ # https://github.com/shr-project/jenkins-jobs/blob/master/jenkins-job.sh
+ INHERIT += "reproducible_build_simple"
+ # We want musl and glibc to share the same tmpfs, so instead of appending default "-${TCLIBC}" we append "fs"
+ TCLIBCAPPEND = "fs"
+ PREFERRED_PROVIDER_udev = "systemd"
+ PREFERRED_PROVIDER_virtual/fftw = "fftw"
+ # use gold
+ DISTRO_FEATURES_append = " ld-is-gold"
+ # use ptest
+ DISTRO_FEATURES_append = " ptest"
+ # use systemd
+ DISTRO_FEATURES_append = " systemd"
+ DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
+ VIRTUAL-RUNTIME_init_manager = "systemd"
+ VIRTUAL-RUNTIME_initscripts = ""
+ # use opengl
+ DISTRO_FEATURES_append = " opengl"
+ # use wayland to fix building weston and qtwayland
+ DISTRO_FEATURES_append = " wayland"
+ PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
+ PREFERRED_PROVIDER_jpeg-native = "libjpeg-turbo-native"
+ PREFERRED_PROVIDER_gpsd = "gpsd"
+ PREFERRED_PROVIDER_e-wm-sysactions = "e-wm"
+ ESYSACTIONS = "e-wm-sysactions"
+ # don't pull libhybris unless explicitly asked for
+ PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
+ PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
+ PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
+ PREFERRED_PROVIDER_virtual/egl ?= "mesa"
+ # to fix fsoaudiod, alsa-state conflict in shr-image-all
+ VIRTUAL-RUNTIME_alsa-state = ""
+ # to prevent alsa-state being pulled into -dev or -dbg images
+ RDEPENDS_${PN}-dev_pn-alsa-state = ""
+ RDEPENDS_${PN}-dbg_pn-alsa-state = ""
+ # to fix dependency on conflicting x11-common from packagegroup-core-x11
+ VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
+ RDEPENDS_${PN}-dev_pn-x11-common = ""
+ RDEPENDS_${PN}-dbg_pn-x11-common = ""
+ # to fix apm, fso-apm conflict in shr-image-all
+ VIRTUAL-RUNTIME_apm = "fso-apm"
+ # require conf/distro/include/qt5-versions.inc
+ # QT5_VERSION = "5.4.0+git%"
+ # for qtwebkit etc
+ # see https://bugzilla.yoctoproject.org/show_bug.cgi?id=5013
+ # DEPENDS_append_pn-qtbase = " mesa"
+ PACKAGECONFIG_append_pn-qtbase = " icu gl accessibility freetype fontconfig"
+ # qtwayland doesn't like egl and xcomposite-glx enabled at the same time
+ # http://lists.openembedded.org/pipermail/openembedded-devel/2016-December/110444.html
+ PACKAGECONFIG_remove_pn-qtwayland = "xcomposite-egl xcomposite-glx"
+ # for webkit-efl
+ PACKAGECONFIG_append_pn-harfbuzz = " icu"
+ inherit blacklist
+ # PNBLACKLIST[samsung-rfs-mgr] = "needs newer libsamsung-ipc with negative D_P: Requested 'samsung-ipc-1.0 >= 0.2' but version of libsamsung-ipc is 0.1.0"
+ PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds"
+ PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much"
+ PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/"
+ # enable reporting
+ # needs http://patchwork.openembedded.org/patch/68735/
+ #ERR_REPORT_SERVER = "errors.yoctoproject.org"
+ #ERR_REPORT_PORT = "80"
+ #ERR_REPORT_USERNAME = "Martin Jansa"
+ #ERR_REPORT_EMAIL = "Martin.Jansa@gmail.com"
+ #ERR_REPORT_UPLOAD_FAILURES = "1"
+ #INHERIT += "report-error"
+ # needs patch with buildstats-summary.bbclass
+ INHERIT += "buildstats buildstats-summary"
+ # be more strict with QA warnings, turn them all to errors:
+ ERROR_QA_append = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+ WARN_QA_remove = " ldflags useless-rpaths rpaths staticdev libdir xorg-driver-abi textrel already-stripped incompatible-license files-invalid installed-vs-shipped compile-host-path install-host-path pn-overrides infodir build-deps unknown-configure-option symlink-to-sysroot multilib invalid-packageconfig host-user-contaminated uppercase-pn"
+ # enable thumb for broader test coverage (oe-core autobuilder doesn't have thumb enabled)
+ PREFERRED_ARM_INSTRUCTION_SET ?= "thumb"
+ ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
+ # use musl for qemux86 and qemux86copy
+ TCLIBC_qemux86 = "musl"
+ TCLIBC_qemux86copy = "musl"
+ # limit parallel make to avoid OOM
+ PARALLEL_MAKE_pn-qtwebkit = "-j 8"
+ filename: "{{.BuildDir}}/world_fixes.inc"
+ fileMode: 420
+ - type: WriteFile
+ fileContents: |
+ #!/bin/bash -xe
+ git clone git://git.yoctoproject.org/poky --reference /mnt/yocto-cache/mirror/poky.git
+ (cd poky; git checkout ${POKY_SHA1})
+ git clone git://github.com/openembedded/meta-openembedded --reference /mnt/yocto-cache/mirror/meta-openembedded.git
+ (cd meta-openembedded; git checkout ${OE_SHA1})
+
+ source ./poky/oe-init-build-env
+ export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE SSTATE_DIR DL_DIR"
+ export DL_DIR=/mnt/yocto-cache/downloads
+ export BB_GENERATE_MIRROR_TARBALLS=1
+ export SSTATE_DIR=/mnt/yocto-cache/sstate-caches/$(sed -n -e "s/DISTRO_CODENAME.*\"\(.*\)\"/\1/p" ../poky/meta-*/conf/distro/poky.conf)
+ bitbake-layers add-layer ../meta-openembedded/meta-oe
+ bitbake-layers add-layer ${SOURCE_DIR}
+
+ echo 'require ../world_fixes.inc' >> conf/local.conf
+
+ # EXCLUDE_FROM_WORLD
+ rm -f ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
+
+ bitbake $(find ${SOURCE_DIR} -name *.bb | xargs -n1 basename | sed -e 's/\([^._]*\).*/\1/')
+ filename: "{{.BuildDir}}/start-build"
+ fileMode: 420
+ - type: ExecuteCommand
+ command: ["chmod", "+x", "{{.BuildDir}}/start-build"]
+ userMessageOnFailure: "Could not add execution right to the start-build."
+ - type: EnvironmentVariable
+ variableName: DL_DIR
+ variableValue: "/mnt/yocto-cache/downloads"
+ - type: EnvironmentVariable
+ variableName: SOURCE_DIR
+ variableValue: "{{.SourceDir}}"
+ - type: ExecuteCommand
+ command: ["{{.BuildDir}}/start-build"]
+ maxTimeInSeconds: 28800
+ maxTimeBetweenOutput: 28800
+ userMessageOnFailure: "Build failed."
+ - type: ExecuteCommand
+ command: ["sudo", "umount", "/mnt/yocto-cache"]
+ userMessageOnFailure: "Unmounting cache failed."
+
+test_instructions: []
diff --git a/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch b/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch
new file mode 100644
index 00000000..5fe840a0
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime/0003-Fix-build-on-musl-libc.patch
@@ -0,0 +1,26 @@
+From f654a25f9df6583532798f30181d149d51b23808 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Thu, 8 Aug 2019 08:34:47 +0300
+Subject: [PATCH] Fix build on musl libc
+
+Use bits/local_lim.h only with glibc as it's not available
+on musl libc.
+
+Change-Id: Ibffa4ab5649b544664f99b16e94d6865148eeeb5
+---
+ src/foundation/linux/Qt3DSLinuxThread.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/foundation/linux/Qt3DSLinuxThread.cpp b/src/foundation/linux/Qt3DSLinuxThread.cpp
+index fa6e069..99c4c3a 100644
+--- a/src/foundation/linux/Qt3DSLinuxThread.cpp
++++ b/src/foundation/linux/Qt3DSLinuxThread.cpp
+@@ -35,7 +35,7 @@
+ #include "foundation/Qt3DSAssert.h"
+ #include "foundation/Qt3DSIntrinsics.h"
+ #include "foundation/Qt3DSBroadcastingAllocator.h"
+-#if !defined(QT3DS_APPLE) && !defined(ANDROID) && !defined(__CYGWIN__) && !defined(__QNX__) && !defined(__INTEGRITY)
++#if !defined(QT3DS_APPLE) && !defined(ANDROID) && !defined(__CYGWIN__) && !defined(__QNX__) && !defined(__INTEGRITY) && defined(__GLIBC__)
+ #include <bits/local_lim.h> // PTHREAD_STACK_MIN
+ #endif
+ #include <stdio.h>
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
index ecc8ba2b..049f885a 100644
--- a/recipes-qt/qt5/ogl-runtime_git.bb
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -18,6 +18,7 @@ SRC_URI += " \
${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
file://0001-Fix-examples-build-error.patch \
file://0002-Fix-format-security-issues.patch \
+ file://0003-Fix-build-on-musl-libc.patch \
"
SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f"